MX1000 won't charge :(

Ohzopants

My mom thinks I'm cool
Joined
17 Jan 2004
Messages
165
The battery in my mouse is down to 1 bar, so I put it in the dock and...
nothing happens!!!

What do I do now?
 

Luna

OSNN Senior Addict
Joined
6 Jan 2004
Messages
303
Make sure the connections are clean on the mouse and in the charger, and that everything is plugged in / connected all the way.

Move it around a bit while it's in there as well
 

Ohzopants

My mom thinks I'm cool
Joined
17 Jan 2004
Messages
165
I tried both those things and it still won't charge... I'm starting to get pissed off.
 

Ohzopants

My mom thinks I'm cool
Joined
17 Jan 2004
Messages
165
Never mind guys, I got it!

P.S.: Did you know that the base doesn't need to be plugged in for the mouse to work, only to charge? I do now. The plug came loose somehow and that's why it wouldn't charge. (Man do I feel stupid now)
 

Members online

No members online now.

Latest profile posts

hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?
Perris Calderon wrote on Electronic Punk's profile.
Hey EP! All good with me, applying for Microsoft MVP right now, should have done this a while ago.

Notifications don't work, I only found your response by coming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier!

Forum statistics

Threads
62,000
Messages
673,425
Members
5,593
Latest member
moussa021