MOuse not working at startup

Mubbers

Shoot!
Political Access
Joined
28 Dec 2001
Messages
1,087
On my new build PC (ASUS Striker Extreme) the mouse occasionally does not come on at startup.

This can simply be rectified by unplugging the mouse and plugging it in again. But this is of course annoying.

Anyone got any idea why this happens?

Appreciated!
 

Perris Calderon

dealer
Staff member
Political Access
Joined
24 Jan 2002
Messages
12,375
On my new build PC (ASUS Striker Extreme) the mouse occasionally does not come on at startup.

This can simply be rectified by unplugging the mouse and plugging it in again. But this is of course annoying.

Anyone got any idea why this happens?

Appreciated!
tried uninstalling the driver and reinstalling?
 

Mubbers

Shoot!
Political Access
Joined
28 Dec 2001
Messages
1,087
tried uninstalling the driver and reinstalling?

Hey Perris! Howya doing? :)

Yeah I tried that, and even included the RAZOR utility at startup just in case. No effect.

It's a RAZOR diamond back mouse BTW.
 

Members online

No members online now.

Latest profile posts

hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?
Perris Calderon wrote on Electronic Punk's profile.
Hey EP! All good with me, applying for Microsoft MVP right now, should have done this a while ago.

Notifications don't work, I only found your response by coming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier!

Forum statistics

Threads
62,000
Messages
673,425
Members
5,593
Latest member
moussa021