mounting ".iso" images in linux and error in mounting FAT32 drive.

gh057

w3lc0m3 t0 7h3 r3al w0r1d
Joined
Aug 23, 2006
Messages
62
#1
hiya i just dual installed linux and windows , having couple of problems here , hehe not really a linux guru :-D anyways i was trying to mount an .iso image in linux i guess the mount commands didnt work anyone have anyideas on how i can do this? dont feel like burning the iso to the cd. ;-( my 2nd problem is i have a FAT32 partition so that both windows and linux can share it however when i try to open the drive linux says " Unable to mount the selected volume."
error: device /dev/hda5 is not removable

error: could not execute pmount


thanx
 

j79zlr

Glaanies script monkey
Political User
Joined
Feb 16, 2003
Messages
2,725
#2
How are you mounting the drive? Is it listed in fstab? What distro are you running?

As for the iso image, the following should mount it:

mkdir /mnt/iso
mount -o loop -t iso9660 filename.iso /mnt/iso
 

gh057

w3lc0m3 t0 7h3 r3al w0r1d
Joined
Aug 23, 2006
Messages
62
#3
How are you mounting the drive? Is it listed in fstab? What distro are you running?

As for the iso image, the following should mount it:

mkdir /mnt/iso
mount -o loop -t iso9660 filename.iso /mnt/iso
sorry dont quite understand fstab? shheheh linux noob :-( and the iso mounting works fine thx, im using ubuntu.
 

Dark Atheist

OSNN Veteran Addict
Staff member
Political User
Joined
Apr 8, 2003
Messages
6,376
#4
the two commands have to be done from a console window

one is to make the mount point (folder in this case where the files will sit)
and the other is to put the files there

fstab = file system table - basically where all the info about how to mount the drives is stored

eg

/dev/hda1 / ext2 defaults 0 0

breaking it down

/dev - tells you its a device
hda - tells you its the first hard drive
1 - tells you which partition it is
/ tell you where its mount - in this case its the main part of the drive - windows c: would be a better way to describe it
ext2 - is the filesystem
defaults - just that default settings for reading writing to the drive
0 0 - how to check the drive should it start acting wierd

generally you can leave these as is

you could try in fastab (norm in /etc)

/dev/hda5 /mnt/point vfat defaults ,rw 0 0

if i remeber right that is - been a while since i had to mount a fat32 or ntfs drive in linux

also if it sounds like im taking to you like your an idiot i applogise, not the intention - just trying to explain it as best i can to a new linux user - i used to be one once :)
 
Last edited:

cheftony

OSNN Newbie
Joined
Oct 27, 2006
Messages
2
#5
ok ubuntu its for noob thats just a easyer version of debian, go to gentoo and chek this out ;) you will realy lear about linux :)
 

Members online

No members online now.

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Hey ep!

All good with me, applying for microsoft mvp right now, should have done this a while ago.

Notifications don't work, I only found your response by comming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier, mine is perriscalderon at gmail
Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...

Forum statistics

Threads
62,030
Messages
673,544
Members
89,041
Latest member
bomblagdi