Microsoft Sidewinder Plug & Play

P

pegusus

Guest
#1
Hi, I have a Microsoft Sidewinder Plug & Play game controller and i've been trying to get it to work for a while, the manual says that once you plug it in windows will look for the drivers, but when I plug it in it doesn't do anything. Can someone help? Just ask for more information if you need more, I really want to get this thing working!
 
P

pegusus

Guest
#3
I've tried it that way, but it doesnt have anything to do with Sidewinder Plug & Play like the manual says, its as if the drivers aren't install, though im guessing thats the problem.
 

LeeJend

OSNN Veteran Addict
#5
Is your account set as the system administrator? If not you may not have permission to install devices. Get the administartor to install it or give you privileges.

If you are administrator make sure you are logged in under the admin account.

FOLLOW the instructions that came with the joystick. Plug and play is a trademark. Not a guarantee of ease of install... Some devices require you to install software/drivers form the CD before connecting the device. I think my logitech joystick requries that.

If you did not follow the instructions the first time through you have to uninstall the device first. Unplugging it should do that hopefully, if not go to the instructions below for using device manager, find the controller name and then right click it and select uninstall. Then reboot and start from scartch with the device unplugged.


Now assuming the easy stuff didn't work:

What operating system? (XP, 2000, 98/ME etc.) XP or 2000 this should be painless (maybe ME too). 98 you need to run setup from the game controller installation CD.

Have you kept the operating system updated? (service packs etc.) There are hundreds of software updates for XP and 2000.

Do you have an internet connection that is always on? (DSL, cable)? If not make sure the modem and phone line are available. If a driver is missing XP or 2000 will ask if you want them to search the MS downloads site for updates/drivers.

Did you plug the controller into the USB port or the gameport?

If you are running XP, or even an updated version of 2000 (it's up to service pack 3 or 4 now) and you plugged it into a USB port it should autodetect and install. If it did not then you may have something wrong with the USB port. The port has to be working before you can do anything. Using the Gameport may not be as easy as the USB port. SO with the device plugged into whatever (game or usb) first off...

Go to start-control panel-double click SYSTEM-hardware-device manager. a long directory like listing of hardware on your system will appear. is anything has a yellow circle with anm exclamation mark in it taht device is not working properly. Make sure everything under "Human interface devices", "sound, video and game controllers", and "Universal Serial Devices" is ok.

If not use right click the yellowed out devie and select trouble shoot. Follow the wizard that pops up it may helkp you fidn the problem.

If everything is ok you need to make sure that the usb or port you are connected to is actually wired in. A few on the back panel are always wired (they are on the motherboard). front panel ports may not be connected to the MB.
 
P

pegusus

Guest
#6
I tried both every way you both described and it still isn't working, my pc isnt recognizing it. I can unplug my printer, scanner and webcam from the usb, plug them back in and it recognizes them, they even installed themselves when i first put them in.
 

BonyTony

OSNN Senior Addict
#10
I have a Microsoft Sidewinder Freestyle pro joypad USB (which is my fave pad) and when for the first time i plugged it in windows Xp just used its own built in drivers to install it, it did not need any and i thought this was the case with all microsoft joysticks and pads.

If windows is not detecting it at all in Device manager under Human Interface Devices then it may be dud...seeing as your other usb hardware works.
 

Hipster Doofus

Good grief Charlie Brown
#11
Which is why I said that up there ^^^^^^

Plugged mine in & away it went. No setting up or calibrating.
If the plug & play is working for other things then .......................
 
#12
I have the Microsoft Sidewinder Gamepad (gameport version). I just plug the pad in and go to game controllers in control panel, choose Add and then Microsoft Sidewinder Auto Detect - it finds the drivers needed and installs them.

Is your gamepad a usb or gameport? USB should work like your scanner and printer, gameport you'll need to do what I normally do above.

If none of that works, then I'd try it on a different computer.
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,971
Messages
673,299
Members
89,016
Latest member
Poseeut