Logitech G15 Media Keys not working

AlexK

Ooops i did it again!
Joined
31 Dec 2007
Messages
42
Hello all :) I just got a G15 as a christmas present, but the media keys doenst seem to work at all.. Ive tried the fix in this thread but the expand string in regedit is allready there.. I also have a MX610 Laser mouse which uses Setpoint.. So if u know any solutions to this i would be extatic :)!!

Everything else on the keyboard works fine..
 
What media player are you using?

My media keys work with WMP11 and VLC as well as the Zune player.

Don't remember using it with other players and I don't use winamp, but it worked with winamp back in the day.
 
If you are using Winamp you have to goto Options> Pref>Global Hotkeys> Then check the first box and second box.
 
Hmm, my replies are disappearing :p

Winamp doenst work. Ive checked the boxes as told, still didnt work..

Maybe my mouse is interferring.? it has 3 media keys ( mute, volume up/down )
 
alex: first posts must be approved by a moderator.. thus the reason the posts weren't showing initially.
 
AlexK - in answer to your pm - try clicking on usercp - top of the page - then edit sig :)
 
Ahh okay fitz, im a new user so i didnt realize it :p hehe sorry .

Carpo , thx im gonna try that :)

#
I found the Edit Signature under my options.. I swear it wasnt there before! :p sorry guys
#
 
Last edited:
Yes i have installed it.. Everything else on the keyboard works fine , except the 5 mediabuttons.
 
look in Control Panel->Administrative Tools->Services - check to see if HID (Human Interface Device Access) is set to auto and started
 
I cant start the Human interface device.. It comes up with this warning

"Could not start the Human Interface Device Acces service on Local Computer.
Error 126 : The specified module could not be found"
 
im guessing you have XP SP2 if so you can either do this from the cd or the system32\dllcache folder

copy hidserv.dll, mouhid.sys and mouclass.sys from XP CD's i386\ directory to windows\system32

or from c:\windows\system32\dllcache
 
Thanks ill try it when i have the time :)

#
didnt find any dllcache in system32?
#
 
Last edited:
The only file on my XP SP2 CD is the hidserv.IN_file

No - mouhid.sys, mouclass.sys or hidserv.dll

Where could i find them then?


#
The hidserv.dll file is not in my Windows folder..
The service is also supposed to run inside svchost.exe.. So maybe its my svchost.exe thats not working?
 
Last edited:
uninstall the logitech drivers - reboot - make sure you reinstall latest drivers, seems im confused between windows versions :p - my xp laptop does not have that file although vista pc does!
 
yes i have a hid.dll

How do i uninstall the drivers? Just uninstall the software? :)
 
Last edited by a moderator:
i have found the files - i was looking in the wrong place

1.Insert Windows XP Setup CD.
2.Browse to <CD-ROM>:\i386\drivers.cab
3.Double click the drivers.cab file. The compressed files in the Cab file
will be listed.
4.Copy the three files to <SystemRoot>\windows\system32\. Reboot the
computer.
 
Last edited:
If you are in windows just launch msconfig then click on Expand File.
 

Members online

No members online now.

Latest profile posts

Also Hi EP and people. I found this place again while looking through a oooollllllldddd backup. I have filled over 10TB and was looking at my collection of antiques. Any bids on the 500Mhz Win 95 fix?
Any of the SP crew still out there?
Xie wrote on Electronic Punk's profile.
Impressed you have kept this alive this long EP! So many sites have come and gone. :(

Just did some crude math and I apparently joined almost 18yrs ago, how is that possible???
hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.

Forum statistics

Threads
62,015
Messages
673,498
Members
5,626
Latest member
FayWilley
Back