Logitech G11 keyboard media keys not working

Heeter

Overclocked Like A Mother
Joined
Jul 8, 2002
Messages
2,732
#1
Hey all,

I got a G11 keyboard, and I cannot get the media keys to work across the top.

Went to Logi's site and in the FAQ's they said that it was the media player's problem.

I am using WMP11.

The installation CD only comes with software to make the gaming keys work.

Can anyone help?

Thanks,

Heeter
 

Sazar

F@H - Is it in you?
Staff member
Political User
Joined
Apr 12, 2002
Messages
14,905
#2
Do you have all the software installed?

I have personally never had an issue in wmp or winamp with the media keys.

If a reboot doesn't fix the issues, I would consider un-installing the drivers and re-installing and seeing whats up.
 

Heeter

Overclocked Like A Mother
Joined
Jul 8, 2002
Messages
2,732
#3
Thanks for the response, Sazar.

I just tried that, uninstall, reinstall. Downloaded the latest from site (Which was the same as cd) and tried those as well.

I will try again,

Thanks again,

Heeter
 

Sazar

F@H - Is it in you?
Staff member
Political User
Joined
Apr 12, 2002
Messages
14,905
#4
Is there absolutely no response at all?

If you have the lcd applet up, see if you have everything enabled that needs be.
 

Sazar

F@H - Is it in you?
Staff member
Political User
Joined
Apr 12, 2002
Messages
14,905
#7
No it doesn't have the LCD display, but you should still have a similar applet running for media key functionality.
 

Heeter

Overclocked Like A Mother
Joined
Jul 8, 2002
Messages
2,732
#8
Hiya guys,

I don't have the little screen, but the "G" buttons applet that runs on my monitor is working perfectly.

The situation is only with the multimedia keys and the mute button.

This G11 keyboard replaced another logitech cordless keyboard, but that one had no issues, straight plug'n'play. Now when I tried using it, it's media keys don't work now either. Go figure.

Thanks for all the help so far guys, Sazar.

Would be nice to get these keys going.

Heeter
 

Sazar

F@H - Is it in you?
Staff member
Political User
Joined
Apr 12, 2002
Messages
14,905
#9
I wonder if there is a conflict between the old and the new keyboard software.

Perhaps you need to clean out some redundant reg settings and files? I can't think of anything else.

My g-15 worked ace off the bat, I just needed the software for the display, the media keys worked from the get-go. Your's should too, there HAS to be some kind of communication fubar (i.e. software mucking it up).

Give it a look see and check in msconfig from run to see if you have any redundant apps running at startup that might be causing issues.

G.luck, keep us posted on what you find out buddy.
 

Perris Calderon

Administrator
Staff member
Political User
Joined
Jan 24, 2002
Messages
12,356
#10
firewall could be preventing the launch also..check to see if you have system protection or sandbox or something like that enabled,
 

Sazar

F@H - Is it in you?
Staff member
Political User
Joined
Apr 12, 2002
Messages
14,905
#11
Firewall? Shouldn't be. It's a direct plug and play product m8. How would the firewall affect that?

I have had issues with multiple logitech products connected to the same system previously (my mx1000 and my mx revolution).
 

Perris Calderon

Administrator
Staff member
Political User
Joined
Jan 24, 2002
Messages
12,356
#12
Firewall? Shouldn't be. It's a direct plug and play product m8. How would the firewall affect that?

I have had issues with multiple logitech products connected to the same system previously (my mx1000 and my mx revolution).
my firewall, (kerio) will prevent any hardware from launcing any program without my permission or a rule, iit won't even let software launch other software without permission or a rule

for instance, the first time I install any program, the first time I launch it the firewall will ask tell me;

"explorer is trying to launch outlook express, you want to allow?"

any time I update a driver the firewall tells me "this program has changed since it was last launched, do you want to allow?"

it's called a sandbox and you don't really need an anti virus with this type of system security

this thing is so **** I think the first time I wanted to leave for the bathroom it made me get permission from myself

I think norton has something similar
 
Last edited:

Heeter

Overclocked Like A Mother
Joined
Jul 8, 2002
Messages
2,732
#13
Here is a screenie of my msconfig

Thanks for the help, guys, Sazar.

I went back to the logi site and could not come up with in the FAQs that addresses this issue.

The logi "Setpoint" is for my mx revolution, which replaced the mx700 with no dilemma.

Heeter
 
Last edited:

Sazar

F@H - Is it in you?
Staff member
Political User
Joined
Apr 12, 2002
Messages
14,905
#14
From that, it looks fine.

I would consider deleting all logitech software and removing all entries if possible and then re-installing and see if that clears things up for you.

Does it not work at all or is it sporadically active?
 

Heeter

Overclocked Like A Mother
Joined
Jul 8, 2002
Messages
2,732
#15
Hiya Sazar,

It doesn't work at all.

I will take another crack at it. I am going to uninstall software, remove entries in C:/Program Files, then I'll hop into the regedit and see about removing entries with logitech in them. I don't have any other Logi stuff other than this keyboard/mouse.

Will get back to you when I complete these tasks.

Heeter
 

Heeter

Overclocked Like A Mother
Joined
Jul 8, 2002
Messages
2,732
#16
Hmmm,

I uninstalled all logitech stuff, then manually deleted file folders, then went through regedit and found a whole swack of logi stuff, and removed anything associated with keyboard and mouse.

Rebooted and still no go, the multimedia keys still don't want to work.

Gonna go to the logi site and see if I can contact someone directly through email or such.

Thanks for all your help Sazar.

Heeter
 

Heeter

Overclocked Like A Mother
Joined
Jul 8, 2002
Messages
2,732
#17
Update:

After a lot of searching, I found this:

Solution to the Media Key Problem Other "Media Keys won't work" Threads didn't help you.
Try this. Make sure you installed the latest drivers from Logitech
:arrow: http://www.logitech.com/index.cfm/do...ontentid=10824
and the MS Service Pack 2
Then go to start -> execute and lauch services.msc and check, if the Hid Input Service at "Startup Type" is set to Automatic and the Service is "Started".
If it's not and you try to start it and get an error like "Code 2....", one
registry key is missing. I've exported my key and tested it with a friend, who had this
prob and it worked.
Open regedit and go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\HidServ\Parameters
Create an EXPANDABLE string value called ServiceDll with the value %SystemRoot%\System32\hidserv.dll
Now it should work.
After the regedit mod, all my keys are now working, including the media keys

Thanks to all.


Heeter
 

Sazar

F@H - Is it in you?
Staff member
Political User
Joined
Apr 12, 2002
Messages
14,905
#18
Yay :D

Heeter FTW !!!

You totally pwned that logitech stuff ;)
 

goomnaga

My Hard Drive Clicks Alot
Joined
Dec 30, 2006
Messages
1
#20
I Just Bought the g11 also and had the same problem and yer guys solution helped me thank very much (i guess Logitech needs to make a software update with this fix eh?)
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Hey ep!

All good with me, applying for microsoft mvp right now, should have done this a while ago.

Notifications don't work, I only found your response by comming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier, mine is perriscalderon at gmail
Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...

Forum statistics

Threads
62,013
Messages
673,491
Members
89,035
Latest member
lilabreeding