• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Linux finds eth0, but yet no eth0?

#1
I have a slight problem with my NIC. It's an onboard NIC (RTL8100) stuck on an Abit BD7II-RAID motherboard. When I try to install Gentoo (or run Knoppix for that matter), the NIC is detected and the system tries to get an IP through DHCP. The problem is the NIC won't light up. When I run ifconfig, eth0 isn't listen, only lo. If I run net-setup (on the Gentoo cd) eth0 turns up, but without and IP and with zeroed stats. Still no lights.

If I check the modules, the rtl8139too driver is loaded as it should be (it's the right one, right?), so apparently it did detect the card.

I know the NIC is ok, the current Windows XP installation uses it and has been for two years.

Any ideas? I'm no Linux expert of any sort, so I'm not at all sure what to do next. :(
 
#2
That's funny, I had the same problem, but that was because I used the wrong cable (Internet --wireless--> Win ME machine --wired--> Linux laptop), I needed a crossover and I used a straight through. Weird shiz, the network.

Anyway, sorry I don';t have a solution to your problem :p
 

X-Istence

*
Political User
#3
As root, run:

killall -9 dhclient

dhclient -vvv eth0

Then see if it says any errors.

You can also bring the interface up yourself with an IP:

killall -9 dhclient

ifconfig eth0 "inet <some IP address not on your network, which your router routes> netmask 255.255.255.0"
ifconfig eth0 up

route add default <your router ip>

If this does not work, then i am sorry, but Linux is not my favorite OS.
 

j79zlr

Glaanies script monkey
Political User
#6
That would really only work if you have the dhcp client daemon installed. It is just a work around for the installation, after it is installed, setting up DHCP should be as simple as just editting /etc/conf.d/net to include iface_eth0="dhcp" Different for every distro.
 
#7
I tried static IP and all, but it didn't work. I managed to solve it now though. I turned off APIC support in BIOS yesterday, which didn't help. But today when I started it suddely worked. It seems I had to turn the computer off after doing the APIC setting, not just restart it. It's the only reason I can find right now anyway. Strange shiit. :D

Now I'm going to install Gentoo, wish me luck! ;)
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,013
Latest member
Pdawgintown