• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Links not working, Microsoft Framework

nod32

OSNN Addict
#1
Hi everyone,

The first problem I have is that no links (to websites) work from any programs (other than links within Firefox and IE). When I press them nothing happens. My default browser is Firefox and Im running Windows Xp pro sp2.

My next problem is with Microsoft Update. It's showing me that I have to update Microsoft Framework to version 1.1. I have version 2 installed right now so im a little confused. I tried a repair install of version 2 (framework) but it's still showing me I need to update.

Thanks for your help,
Matt
 
#2
For your first issue, try using SetBrowser to reset your default browser setting. Reboot once after you use it, just for good luck. :)
http://www.pc-tools.net/win32/setbrowser/

Your second issue isn't actually an issue. The .NET framework supports multiple versioning. Apps that are built for .NET 1.x need to run on the .NET 1.x CLR, even though the .NET 2.0 runtimes are installed. The update notification comes up in WU because you need to update from .NET 1.0 to 1.1. The 2.0 CLR will remain unaffected by the update.
 

nod32

OSNN Addict
#3
The links work! :)
Thanks a bunch.

But I have all the versions installed (1.0, 1.1, 2.0). Its all in C:\WINDOWS\Microsoft.NET\Framework. Any ideas?

Thanks
 
#4
Glad it worked. :)

The .NET update could be a new minor version then. Go ahead and install it. It shouldn't do any harm. If it still shows up on WU after you install it, then you'll know something's wrong.
 

nod32

OSNN Addict
#7
I installed Microsoft.NET Framework 1.1, Service Pack 1 for 1.1, and a security update for 1.1 and everythings good now.

Thanks:)
 

l_brubaker15

OSNN One Post Wonder
#10
nod32 said:
Hi everyone,

The first problem I have is that no links (to websites) work from any programs (other than links within Firefox and IE). When I press them nothing happens. My default browser is Firefox and Im running Windows Xp pro sp2.

My next problem is with Microsoft Update. It's showing me that I have to update Microsoft Framework to version 1.1. I have version 2 installed right now so im a little confused. I tried a repair install of version 2 (framework) but it's still showing me I need to update.

Thanks for your help,
Matt
yeah mine doesnt work either
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,013
Latest member
Pdawgintown