Itunes is sluggish with Vista 64-bit

Vanquished

Mr. Bananagrabber
Political Access
Joined
12 Jan 2006
Messages
4,869
Hey everyone, I have a vista 64-bit computer with Itunes on it, I have Itunes version 7.7.1, the newest version yet it still is extremely sluggish when it comes to scrolling or searching, or doing pretty much anything else.
Does anybody know why?

Thanks,
jack
 

Mizzle

Oh, now I know...!
Joined
3 May 2008
Messages
347
Well, Apple does have some Vista issues when it comes to iTunes. The same thing happens on my lappy, and it's also just black when opening the application.
 

Sazar

Rest In Peace
Joined
12 Apr 2002
Messages
14,905
Works fine for me.

Only time I have any kind of issue is the interface does not refresh if I have itunes maximized and I have another application open in the fore-front that I close.

However, a quick minimize/maximize restores it.

Maybe there is a known issue with something else you have in your hardware/software configuration?
 

Vanquished

Mr. Bananagrabber
Political Access
Joined
12 Jan 2006
Messages
4,869
Works fine for me.

Only time I have any kind of issue is the interface does not refresh if I have itunes maximized and I have another application open in the fore-front that I close.

However, a quick minimize/maximize restores it.

Maybe there is a known issue with something else you have in your hardware/software configuration?
Hmm Maybe, oh well, I guess there is not fix. The only reason I even have Itunes is because of the Iphone anyways...
 

Sazar

Rest In Peace
Joined
12 Apr 2002
Messages
14,905
Same here. I think it has some nice features but it broke all my tagging from my Zune app (which worked flawlessly for album tagging and pulling updated album-art btw).

Considering that it's supposedly a native 64-bit app, you would think the app would work better but.... c'est la vie.
 

Vanquished

Mr. Bananagrabber
Political Access
Joined
12 Jan 2006
Messages
4,869
Same here. I think it has some nice features but it broke all my tagging from my Zune app (which worked flawlessly for album tagging and pulling updated album-art btw).

Considering that it's supposedly a native 64-bit app, you would think the app would work better but.... c'est la vie.
Haha Yeah.
 

gonaads

Beware the G-Man
Political Access
Joined
31 Mar 2002
Messages
18,474
Hey Vanquished did you D/L the 64 bit version? Sazar is saying that it's a native 64 bit app but I found this on a forum where someone had/has same problem as you.

http://forums.hexus.net/operating-systems-applications/138553-vista-64-bit-version-itunes.html

Odd thing is that on the iTunes page iTunes v7.7 it shows the download is same for both 32bit XP with SP2/Vista 32bit and the 64bit Vista. Hmmmm.



Seems that as of v7.6 of iTunes it will play nice with Vista 64. And you posted that you have v7.7.1

http://www.engadget.com/2008/01/15/apples-itunes-7-6-plays-nice-with-64-bit-vista/



This is direct from Apple.

http://support.apple.com/kb/HT1426


This is all I could fine that seems could have been an issue.

[edit]

Question, How are your video drivers? It could be a video thing.

Found this about Cover Flow being very slow and ForceWare drivers. But it's dated.

http://forums.macrumors.com/showthread.php?t=317186
 
Last edited:

Vanquished

Mr. Bananagrabber
Political Access
Joined
12 Jan 2006
Messages
4,869
Hey Vanquished did you D/L the 64 bit version? Sazar is saying that it's a native 64 bit app but I found this on a forum where someone had/has same problem as you.

http://forums.hexus.net/operating-systems-applications/138553-vista-64-bit-version-itunes.html

Odd thing is that on the iTunes page iTunes v7.7 it shows the download is same for both 32bit XP with SP2/Vista 32bit and the 64bit Vista. Hmmmm.



Seems that as of v7.6 of iTunes it will play nice with Vista 64. And you posted that you have v7.7.1

http://www.engadget.com/2008/01/15/apples-itunes-7-6-plays-nice-with-64-bit-vista/



This is direct from Apple.

http://support.apple.com/kb/HT1426


This is all I could fine that seems could have been an issue.

[edit]

Question, How are your video drivers? It could be a video thing.

Found this about Cover Flow being very slow and ForceWare drivers. But it's dated.

http://forums.macrumors.com/showthread.php?t=317186
Well, I did download the 64 bit version, but in task manager it says its the 32 bit version, and My video drivers are all up to date, hmm....
Thanks,
jack
 

Mizzle

Oh, now I know...!
Joined
3 May 2008
Messages
347
I downloaded the 64-bit version as well, and also here it shows as a 32-bit version in task manager.
 

Members online

Latest forum posts

Latest profile posts

Also Hi EP and people. I found this place again while looking through a oooollllllldddd backup. I have filled over 10TB and was looking at my collection of antiques. Any bids on the 500Mhz Win 95 fix?
Any of the SP crew still out there?
Xie wrote on Electronic Punk's profile.
Impressed you have kept this alive this long EP! So many sites have come and gone. :(

Just did some crude math and I apparently joined almost 18yrs ago, how is that possible???
hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.

Forum statistics

Threads
62,011
Messages
673,478
Members
5,607
Latest member
rohitprabhakar