• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Installing XP...


Beware the Monkeys!!!
Ok, I have installed Windows XP, probably a million times. I am setting up dual boot system, (98SE/XP), the 98 side is done. When I go to install XP, it keeps stopping when it copies the files for the setup, and always on the shell32.dll. I am at my wits end. Any ideas would be greatly appreciated!
Stupid question, but have you cleaned the CD and checked for scratches any time during those million installs?

If the CD is scratched try making a copy. If you are successful do the install form the copy. If copy won't work see if you can borrow a cd. They are all the same, it's just the key that is private.
Try this

Copy the contents of your XP cd to a new folder in your c: drive e.g. c:\winxp. Make a win98 boot disk and then copy smartdrv.exe to it (find it in \windows or on the win98 cd).

Boot with the win98 boot disk, type 'smartdrv' WITHOUT any switches at the a: prompt (speeds up file transfer big time!!!), cd into c:\winxp\i386\ and type 'winnt'.

XP should install as normal, only from the hard drive instead of cd.

This may solve your problem.


Beware the Monkeys!!!
I will give that a try!!! I have another trick up my sleeve also. I have a XP backup from a while ago, so I can try to restore it to the drive I want.


Beware the Monkeys!!!
sraycoz: I have some old games that just run better under Windows 98, than on XP, even with compatibility mode. Just as a side note, this is my 4th computer. My wife has hers, I have mine, we have a guest computer, and this one that I am goofing around with. The first 3 systems all have Windows XP Home w/SP2 installed.

RickyC: Guess what, it didn't work. It stopped again on shell32.dll. Next will be the restore of the backup I have. We will see how that works.
I'm guessing it may be a memory related problem or bad sectors on the hd. Setup is probably trying to write to the same part of memory each time.

Run a memory test, http://www.memtest86.com/ or http://www.sisoftware.co.uk/ I'm sure there's plenty more out there, just can't think of any atm. See if you get any errors. Same with the hd.

The backup may work, only problem is XP likes to own the MBR. You may have to run FIXMBR from the XP recovery console afterwards.


Beware the Monkeys!!!
The memory had already been tested, even with that I did swap memory, just as a double check, but no go. I will have no issue using the backup, even with XP being picky about it. I will let you know what happens next.


Beware the Monkeys!!!
Unfortunately the memory all checks out fine. I did complete an installation by skipping the shell32.dll, and everything seems to be fine. I used XOSL to do the multiboot and everything is working. If something else pops up I will let you know.


Beware the Monkeys!!!
Well, I decided to run MemTest86 again, and guess what it passed 12 times so far, absolutely no errors. Something is happening though. I went to install Nero and it keeps saying that the executable is corrupted. I ran from across the network, copied the file to the system and even downloaded, and it kept doing the same thing. Now that definitely sounds like a memory issue, but why would the memory still pass all the tests?


There is no answer!
Political User
ok question, with your dual memory, how many slots do you have, for instance i have 4 dimm slots and i have to have two identical mem card in 1and 3 and 2 and 4, can you picture what i'm saying? make sure that configuration is the same as yours, probably wont make much difference but it might other suggestion. Take out one of your mem sticks and test each one in turn. see it one of the sticks is the issue. Another suggestion, try and borrow memory from a friend and put in in your machine taking out your and see if that solves the issue. or try using your mem in another pc.
Sounds like either the CD reader or the HD has a problem. I have had Windows installs hang before and I tracked it back to a HD that was going bad on me.

1) Try Installing from another CD drive or do the copy windows to the HD trick above.
- If this works try cleaning the optical drive (they have cleaning kits).
- If this doesn't work go to step 2.

2) Run the HD vendor Diagnostics including a total read/write check of the HD.
-If it passes reformat the drive and do a track 0 repair.
-Try the install again.
- If it fails it could be in the IDE cables or MB controller.

Unlikely its a power supply issue, thats a good one you have.

I just re-read the old posts and came up with another question on the previous successful installs you've done:
-Were the previous succesful installs with a slipstreamed SP1 or earlier and you are now trying the install with a slipstreamed SP2?


Beware the Monkeys!!!
The computer in question, is not the one listed, I apologize for the confusion. The specs are as follows:

Abit KT7A v1.1 BIOS A9
Athlon Thunderbird 1Ghz/200FSB
448MB PC100 SDRAM (256,128,64)
3Dfx Voodoo 5 5500 Video Card
Soundblaster PCI512 Soundcard
Netgear FA310TX 10/100 NIC
Belkin 2-Port USB 1.1 Card (Onboard USB is nonfunctional and disabled)
3.8GB Maxtor
4.3GB Seagate
19.2GB Quantum (5 1/4" drive)
Compaq CD-ROM
Power Supply 235Watt (I know its low but it powers everything fine)
Basically, Windows 98SE installed on the 3.8, Windows XP Home on the 4.3 and the 19.2 is shared between the 2.

I tried other Windows install discs and they all did the same thing. The original release of Windows XP Home is what I am starting with. I will do the HD checks and see what happens.

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member