• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

IDE detection prob on A8n-Sli


OSNN Junior Addict
Hi all

I am currently building a new pc, with the asus a8n-sli mobo. I have attached a SATA hard drive which has detected ok, but it fails to detect my IDE DVD drive in the BIOS so I am unable to load XP!

I have tried another CD drive and another cable and have checked the jumper settings (which is set to master), but have not had any luck. When I change the bios setting from auto detect to CD drive and reboot it says there is not a compatitable ATAPI drive connected, although both drives work ok when I plug then into another pc with the same cable/jumper setting.

I have flashed the BIOS but I am still unable to detect any IDE drives. I tried phoneing Asus but they said they do not have any motherboard support and to go online! Are there any setting in the Bios that could be causing the problem? I guess my last resort is to buy a SATA cd drive, but it will be very annoying not to be able to use the IDE channels.


Thanks in advance


OSNN Junior Addict
First of all I would change the jumper settings on the DVD drive to cable select instead of master or slave and see how that works out. I have the A8N-E board and seem to remember something about a bios setting that will force the board to work with SATA or IDE drives exclusively, or as a third setting it will support both at once..you might want to check that out too.


OSNN Junior Addict
I think I have already tried cable select but I will try again when I finish work. I was thinking there must be a setting to enable the IDE part of things but I cannot find it. I guess I will have another look. Most of the IDE config I found related to the raid config or which SATA drives you want to enable.



OSNN Junior Addict
Seems I was thinking of my old board concerning the IDE/SATA recognition setting, I just checked my settings and have this to offer.

Get into BIOS and navigate through Advanced, Onboard Device Configuration, IDE function setup...everything here I have set to enabled (which as far as I know should be so by default upon a BIOS flash), all you really need to check though is the IDE channel your drive is plugged into, my DVD writer is plugged into the blue coloured IDE channel which is primary and I've set the drive jumper to CS. Your drive should be detected as the Primary IDE Master, and your hard disk detected as First SATA Master if all is well.

It's also worth checking that the power connector on your drive is not loose, you can always try ejecting the drive while in BIOS to see if it's getting power in your rig.


OSNN Junior Addict
Looking at the manual there is not a section for ide config in the advanced, only on the main screen and this just has config options for the SATA ports (e.g. enable or disable them).
However under advanced there is an option to change the parallel port mode from EPP to ECP, not sure if this is whats needs changing? Coild be completly off track here :crosseyed:



OSNN Junior Addict
I'm not sure how similar our BIOS screens are gonna be but if you've flashed you might wanna head back into the BIOS and check what's there because between revisions things can start to look pretty different. Basically all you're looking for is a way to enable the IDE channel your drive is on, and switch detection back to automatic.

I'll grab the a8n-sli manual from the Asus site and edit this post in a bit.

According to the manual I'm looking at you do indeed have the same IDE Function Setup, don't forget it's in 'Onboard Device Configuration' under Advanced. Download the latest English PDF manual for the A8N-SLI and it's chapter 2 (2-22 & 2-23).
Last edited:
Things to check in the most likely order.

Take the jumper out on the back of the DVD. Empty is the correct setting for a single drive, not master. This could stop it from being recognised by the bios.

Are you sure it is a good DVD drive? Have you tried it in another computer?

Are you installing the ide cable correctly? They are supposed to be keyed but some are not. The red strip goes on the side marked pin 1 on the MB and drive.

Does the tray open and close when you hit the button? If not you have a power connection problem.

When DVD's first came out you could not load Windows from one. I thought that was no longer a problem with the newer MBs and Bioses but you could have an incompatible setup. Find an old CD drive and try to load from that.

Make sure you flashed the correct Bios version.


OSNN Junior Addict
Ok I have removed the jumper but it still cannot detect. I know the drives works fine as it has come out of a working machine, I can also eject the drive.
The only thing I can think of is that I am still missing something in the bios to enable PATA devices. When you go to the IDE config menu in the bios, there is just the config for the SATA. The bios version is 2.58, if you know what I may need to do!?



OSNN Junior Addict
So you are not seeing OnChip Channel0, OnChip IDE Channel1, IDE DMA Transfer Access...etc at the top of the IDE setup section?

I'm not sure what BIOS you're using either but x.xx isn't how Asus name their BIOS revisions. The latest non beta should be v1014, are you downloading from the official site?

Go here: http://support.asus.com/download/download.aspx?SLanguage=en-us&model=A8N-SLI

The latest BIOS for the A8N-SLI should be at the top of the screen, or click the BIOS tab for a full list of revisions.


OSNN Junior Addict
Good news! Last night I had exhausted all other options, so I took the board out of the case and booted outside on a ESD mat...and it picked up ok. following a inspection of my case I found there was a very fine thread of the case coming into contact with the board. I had used nylon nuts and bots to ensure there had not been any bad earth contact but this must have pushed out when I bolted the board back on.
I have used some cutters to cut the bit of metal off and put the board back in and its now fine!

thanks for all your help.


Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member