I am invincible! Userenv errors figured out


Somewhat eXPerienced
Sadly though you CAN'T FIX IT!!!!!!!

I have been going through ALL of my services, and the only service that I can disable and make everything shut down correctly and not incredibly slow getting Userenv errors is...

*Drum roll please*

Plug and Play!

That's right, with Plug and Play enabled, people who get Userenv errors and the incredibly slow shut down process are stuck without a fix as far as I know... anybody have any further information?


Happy you worked this out (let's hope it's the final fix and it doesn't pop out again)

Let me tell you though... PnP is most likely the symptom rather than the cause: I bet (not all) your hardware is on the Windows HCL and runs with non WHQL drivers...

Tell me about it...


Somewhat eXPerienced
Well my main assumption is that MS is going to have to come out with a fix for the userenv errors, because PnP is the one service that pretty much you HAVE to have, and after turning everything else off, then turning that off, it worked... so it's still going to be happening, but at least I've figured out what was causing it. I am still unaware of any fixes. I was contemplating on if I should begin uninstalling some Windows Updates, but they're all numbers so I dunno what to install and what I'm uninstalling and the such, which is really sucky.
by 'Userenv error' do you mean this stupid error??

Windows saved user VALHALLA\oDin registry while an application or service was still using the registry during log off. The memory used by the user's registry has not been freed. The registry will be unloaded when it is no longer in use.

This is often caused by services running as a user account, try configuring the services to run in either the LocalService or NetworkService account.

cuz if you know of a fix for it, i will worship the ground you walk on. no matter what i do i can't get rid of it.


Somewhat eXPerienced
Yeah Odin, that is the very same error of which I have entirely no idea how to fix it. As Rootz suggested, something may be causing PnP to be causing the error, that of which I have no idea. I am lead to believe that one of the Windows XP Service Updates is to blame, but I don't know which ones to install, as all they are is numbers. :/