• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

HOWTO: Install Nvidia Drivers in Ubuntu (or possibly any other linux distro)

lancer

There is no answer!
Political User
#1
This is copied directly from the cornell linux site... it was so helpful that i think i should paste is here, it took me 2 weeks to finally get the nvidia driver to work... after many useless instructions from so called experts... this eventually worked AND it was nowhere near as complex as the other instructions


Note that installing the nVidia driver will automatically fix some screen resolution problems.

http://www.cs.cornell.edu/~djm/ubuntu/#restart-gdm (this page also has many other useful tips).
  1. Install the driver (only if you have an nVidia grapics card): sudo apt-get install nvidia-glx
  2. Enable the driver: sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup.nvidiasudo nvidia-glx-config enableIf there was an error message, you might have to enable the driver manually as follows: sudo gedit /etc/X11/xorg.confReplace: Section "Device" ... Driver "nv" ...EndSectionwith: Section "Device" ... Driver "nvidia" ...EndSection
  3. (optional) Create a desktop entry for nVidia Settings (accessed via the "Applications / System / nVidia Settings" menu): sudo gedit /usr/share/applications/nvidia-settings.desktopAdd the following to the blank file: [Desktop Entry]Name=NVIDIA SettingsComment=nVidia SettingsExec=nvidia-settingsIcon=Terminal=falseType=ApplicationCategories=Application;System;
  4. (optional) Disable the nVidia splash screen: sudo gedit /etc/X11/xorg.confChange: Section "Device" Identifier "NVIDIA Corporation ..." ...EndSectionto: Section "Device" Identifier "NVIDIA Corporation ..." ... Option "NoLogo"EndSection
  5. (optional) Restart Gnome Desktop Manager for these settings to take effect.
 

ElementalDragon

The One and Only
#2
this might be helpful for me if i could actually install Ubuntu. this is the second version i tried to install that i couldn't. the first time i tried to install it with a much older build (and quite a while ago at that), it would boot into the installer, but wouldn't detect my optical drives (figure that one out). now, i tried installing the latest Ubuntu build (think it was the x64 version), it boots, i choose to install, it shows a sort of Ubuntu loading screen, and just sits there.
 

lancer

There is no answer!
Political User
#3
wow, i have never had a lick of problems installing ubuntu, just that one driver and i only had to install that to get the 3d effects for my screensavers, otherwise the actual driver was detected but only or 2d images...

i'm using the 32bit version. but so far ubuntu is just blowing me away, plus it is so fun to try and figure this stuff out.
 

Mainframeguy

Debiant by way of Ubuntu
#4
ED - are you using the 64 bit for any reason? I suspect that was your mistake, take a dapper 32-bit.... if that gives you any problems at all with install I would reconsider whether Linux is for you - personally....
 

Mainframeguy

Debiant by way of Ubuntu
#6
OK - so, now, you are using a 64 bit OS? Because if Ubuntu didn't go on 64 bit I'm confused.... If it was just for kicks I think you may get more kicks with an OS that installs :p And I think Ubuntu regular will do that, let us know maybe?
 

tdinc

█▄█ ▀█▄ █
Political User
#8
Nice post lancer :) Hopefully the next major build will incorporate a better choice of drivers. screen res. was my only issue with a build install. (dapper)
 

ElementalDragon

The One and Only
#9
mainframeguy: nope..... right now using XP, the x86 version, have a second hard drive with a backup partition, and another partition on that hard drive separated for HOPEFULLY a bit of Linux play. i tried to install the 64-bit version of Ubuntu quite recently, it gave me the menu to choose to install and stuff, so i chose to install it, it went to this screen that showed the Ubuntu logo with i think a progress bar at the bottom, and stopped. don't remember even hearing any HD activity.

just downloaded the x86 version of Ubuntu.... only took an hour (gotta love torrents). probably install that either now, or later tonight.
 
#11
*points to signature*....

and...... nope, not even the x86 version of Ubuntu would install..... *sigh*. put the disc in, it booted to the disc, i chose option 1 (boot or install from the disc), but had to use the "noapic" modifier to do so. it started doing stuff, and i had to step out for a few minutes. came back, and all that was on my monitor was the usually blinking underscore mark...... but wasn't blinking.
 
#13
....by the looks of it, since i wasn't able to do anything upon returning to my computer.... i'm kinda guessing not. maybe they still don't have any support for NForce 500 series boards in the latest build?
 

Mainframeguy

Debiant by way of Ubuntu
#14
*points to signature*........
HMMMmmmm that's some pointless pointing!

You should make/link to (I recall you already made it, but maybe that was for the x64 Ubuntu?) a thread for help to resolve this.... if it is indeed Nvidia card you should be good to go - I am also with my ATI... you really need to be installing verbose if troubleshooting...
 

Mainframeguy

Debiant by way of Ubuntu
#16
oh no it doesn't it is chopped by Vb since the forum updates went in - least it is for me. So that GeForce is Nvidia chipset right? Better be to be on this thread and my memory is that GeForce are exclusively Nvidia, right? [edit[ ah the 2x thinger may well be causing Ubuntu to stall, exotic GFX are one of the Linux stumbling blocks occasionally - do check out www.justlinux.org - they can probably get you going if you want them to... channel on freenode too if you IRC
 
#18
just tried to install again. apparently it just doesn't want to boot to the Live CD. is there any way to install Ubuntu without booting to it? like a different option i can add to the command, something like the "noapic" option i have to add to even get as far as i can with booting to the CD?

it comes up with the menu, i press f6 for more options. i add "noapic" to the command line, press enter. it comes to the Ubuntu loading screen, where it loads the Live CD users and stuff like that, all that stuff get's loaded, goes to the black screen with the white blinking cursor in the far top left corner, and after a couple seconds, the cursor stops blinking, and eventually the CD-ROM drive spins down.
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,014
Latest member
sanoravies