Help can not locate driver for sound card.

B

Bishop

Guest
I had installed XP on my 2nd pc. things were getting really screwy and I did not have the option to revert back to 98 so I did a quick restore

After I restored my system to 98 I can not get my sound back. I get these 2 yellow question marks in my Device Manager:

1. PCI Communications Device
2. PCI Multimedia Audio Device

2nd one of course is my sound card (I think) I can not get them to automically find the drivers and install them.

Please help

TIA
 
We need to know what kind of sound card it is. If it's integrated with your motherboard, then we'll need to know what motherboard.
 
The 1st 1 is your modem, the 2nd is your soundcard.

What sort of soundcard is it ?
Have you been to the manufacturers website and downloaded the drivers ?
 

Members online

No members online now.

Latest profile posts

Also Hi EP and people. I found this place again while looking through a oooollllllldddd backup. I have filled over 10TB and was looking at my collection of antiques. Any bids on the 500Mhz Win 95 fix?
Any of the SP crew still out there?
Xie wrote on Electronic Punk's profile.
Impressed you have kept this alive this long EP! So many sites have come and gone. :(

Just did some crude math and I apparently joined almost 18yrs ago, how is that possible???
hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.

Forum statistics

Threads
62,015
Messages
673,496
Members
5,625
Latest member
vinit
Back