Help can not locate driver for sound card.

B

Bishop

Guest
I had installed XP on my 2nd pc. things were getting really screwy and I did not have the option to revert back to 98 so I did a quick restore

After I restored my system to 98 I can not get my sound back. I get these 2 yellow question marks in my Device Manager:

1. PCI Communications Device
2. PCI Multimedia Audio Device

2nd one of course is my sound card (I think) I can not get them to automically find the drivers and install them.

Please help

TIA
 

Lonman

Bleh!
Joined
2 Dec 2001
Messages
2,642
We need to know what kind of sound card it is. If it's integrated with your motherboard, then we'll need to know what motherboard.
 
M

MatrixUK

Guest
The 1st 1 is your modem, the 2nd is your soundcard.

What sort of soundcard is it ?
Have you been to the manufacturers website and downloaded the drivers ?
 

Members online

No members online now.

Latest profile posts

hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?
Perris Calderon wrote on Electronic Punk's profile.
Hey EP! All good with me, applying for Microsoft MVP right now, should have done this a while ago.

Notifications don't work, I only found your response by coming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier!

Forum statistics

Threads
61,999
Messages
673,424
Members
5,593
Latest member
moussa021