• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Games crash to desktop....sometimes??!!!

C

codeblue

Guest
#1
Every time I try to play any games, they unexpectedly drops to the desktop.

I have recently updated to SP1 and installed the most recent ATI drivers for my 7200 graphic card.

I've tried uninstalling these drivers but no joy. I have re-installed XP pro then SP1 with no joy.

I can’t pinpoint what is causing this. I can be playing Links 2003 in the evening, leave my PC on over night, then play again the following evening and it won’t work?

I've tried turning off screen saver and running a diagnostic on DirectX.

The only thing I have to go on is that Links Golf 2003 reports that theirs a problem with 3D acceleration. Also when trying to run the DirectX "Test Direct3D" it fails saying I pressed a key and candled the test.....which i didn't!

I have a Logitech cordless keyboard, so I removed the batteries and ran it again, still with no joy.

HELP PLEASE!!!

Athlon 1800+
512 DDR
XP pro, SP1
ATI 7200 64Mb vivo
Creative Live drive


Thanks in advance.:D

codeblue

I have posted this problem on varuious other sites (Mrb). You can read the repsonces by following the links.:

http://groups.msn.com/ComputerInter...essage=31527&LastModified=4675397698580981811

http://groups.msn.com/GlobleCompute...Message=1925&LastModified=4675397699389067182

http://groups.msn.com/WindowsXPTria...Message=2249&LastModified=4675397699705956232
 
#2
I had kinda the same prob since, sp 1, but my games minimise to the taskbar, does this happen 2 u or do they just crash? 4 some reason i uninstalled my keyboard drivers, and i had the problem alot less. also u say u have uninstalled the drivers, have u uninstalled the graphics card all 2 gether? try that. if not try a restore.

cya
 

Gus K

NTFS abuser
#3
Well this could be a tough one. First I'm not the biggest fan of always loading the latest and suposedly greatest drivers. If it ain't broke don't fix it. Many people have problems with SP1 so you are not alone.

-You might check to see if your vid card is on it's own IRQ.
-You could try running your game in w98 compatibility mode

You can't just ignore the failure of the directX diagnostics, this would appear to be a problem, borrow someone's regular keyboard and try again. Re-install or update DX if it still fails. To me, this is important.

Many people have chosen to not apply SP1 because it didn't work well with their configuration. One size does not fit all.

If you reload you should try things in steps, one at a time, trying/testing each change.
 
#5
maybe links 2003 isn't compatible with your card. then again, you may need to change some settings inside the game.

just a thought...
 
C

codeblue

Guest
#6
In Administrative Tool, in Event Viewer, on the right is says:


Application Log Application Error Records 384.0kb
Security Log Security Audit Records 64.0kb
System Log System Error Log 512kb


Thanks for replying all

Proplem still their though.

All games dont work, not just Links.

Although when i start up Lord Of The Rings 'Fellowship of the Ring' it trys realy hard to minimize to Desktop and i can see the Notification arer (bottom right of task bar) flickering and the arrow cursor as well as the in game cursor. Needless to say the game wont work anyway.

should of stuck with the 48K speccy!
 
C

codeblue

Guest
#7
I dont know how to do this.?


You might check to see if your vid card is on it's own IRQ.
 
C

codeblue

Guest
#10
hers my sys info.

Tryed changing keybord. Gus_K, with no joy.

How do i re-install Direct X running XP pro? I thought it was built in?
 
C

codeblue

Guest
#11
Gus_k....

I uninstalled my keybord drivers reset machine with standered keybord pluged in.....Games didn't work.

Re-set machine with Logitech keybord in again. Games worked. Driect X 3d test worked?????!!!!!

Might of found cause? Now for cure.

This problem is intermitent to although it is solved now, it might not be tomorrow. But because of the Dirext test faliour thing i suspected it was the keybord. But in what way i dont know?
 
#13
YIPPIEEE! yeah i solved the problem. Ok this worked on my pc dont know if it will work on others. Reinstall your directx and everything will be fine. To reinstall use the attached program or install a game which use directx 8.1

Im so glad i can play my games :D
 
O

Orpheus

Guest
#14
I have EXACTLY the same problem (minimizing to taskbar, direct3d test cancelled by pressing a key) for over a year now...

i have windows xp pro on an AMD 1900+, 256 DDR, nVidia TNT2 M64 videocard (I know, I know).

I have tried everything: new BIOS, new AGP driver, 10 different nVidia drivers, re-installation of windows, got the SP1, got directX9.0, you name it. I tried a brand new GF4MX videocard, I bought a brand new TFT monitor...Nothing works.

But, I figured out this: when i create a new account with only user access, everything works. But when I give that same account administrator access, 3d fails again. When i remove the administrator abilities of that account again, it works perfectly again! So, the problem lies somewhere in the settings for the administrator account. After re-installation everything works only one time, untill you turn off the PC and restart, then it's gone again, accept for the limited user account.
 
O

Orpheus

Guest
#15
Guess what: I found the problem. It was a problem in my mouse or keyboard driver. I downloaded the newest driver for my logitech mouse, and deleted the driver for my safeway multimedia keyboard. Now, 3d is running fine, the only thing is that i do not have proper drivers for my keyboard, and xp doesnt load them propertly. The multimedia keys don't function. But he, 3d works, so why bother?
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,013
Latest member
Pdawgintown