• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Function key question

st4rk

OSNN Addict
#1
While in a boot cd, like windows xp, my function keys seem to be disabled, how can i activate the Fn keys? At the moment they are in what i would call their secondary function but it seems to be active will in the boot cd.
 

Mainframeguy

Debiant by way of Ubuntu
#2
I know what you mean - I think - you have a keyboard with a button that enables regular FN key access, operating like a caps lock, but for fn keys (perhaps a media kb?)... I believe if this is defaulting without regular FN access it is a feature of the kb manufacturers, not sure there's a way to change it.

Can't you just press the "F-lock" key (or whatever it is called)?

Post back if my understanding is correct - and with the make/model of the kb in question... is it wireless? Did it come with driver disc and tools? Do you have an alternative regular PS2 keyboard? The latter is an obvious quick fix and these can be had for very little (EG £3.95 I once paid!) and, if you are ordering over £200 hardware they sometimes ship a free keyboard from OCUK - I know because I made an order including a keyboard and they really went th eextra mile and shipped me a free one! Kinda annoying given I just bought one in the order! :D

[edit] aha!
Logfile of HijackThis...
C:\Program Files\Netropa\Multimedia Keyboard\nhksrv.exe
...
O4 - HKLM\..\Run: [HotKeysCmds] C:\WINDOWS\System32\hkcmd.exe
...
O23 - Service: Netropa NHK Server (nhksrv) - Unknown owner - C:\Program Files\Netropa\Multimedia Keyboard\nhksrv.exe
...
I guess this will lead to some answers! Seems you are having a bad time ATM, given you cannot boot to sort these things to get your Fkey working!

Hopefully the simple keypress thinger will help

If able try this and see

- or if all else fails hopefully you can easily just get another kb!

Let me know (and do that star thinger - I went a bit OTT on this post!)
[/EDIT]
 
Last edited:

st4rk

OSNN Addict
#3
Its standard PS2 keyboard made by smart office keyboards, with no extras as far as i can tell, and i cannot see an F-Lock key on it and nowhere in the control panel options is anything about turning on the Fn keys, this is usually fine but the boot cd insists that i press f8 to accept... i have the EZ - 8000 which doesn't show on that list, is it worth getting a later model update and trying that e.g. the EZ 8800?

No the tempremental computer i have here is actually running fine today... but still no help in the F-n key department, cas i don't know where to look to change it.
 
Last edited:

lancer

There is no answer!
Political User
#6
st4rk, make sure there is not a bios option disabling the F keys

Also admiral the compaq kbs used to have an fn key to lock the f keys... not sure why though.
 

Mainframeguy

Debiant by way of Ubuntu
#7
they do it on multimedia kb's (I have at least two like this) in order to free up the F-keys for multimedia operations.... these are still current - not top brands though, typically wireless and cheap(ish)
 

st4rk

OSNN Addict
#9
Thanks for the help guys, managed to get hold of another keyboard which solved the problem, did not see the option in the bios either :( Reformat and reinstall all done. :)
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,014
Latest member
sanoravies