• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

FTP + Router = god help me

#1
using WS_FTP to connect to a server via FTP (dur). also have router... i stuck a screenshot in here of the menu in question, was hoping some networking god could help me figure this out

i have all of the right things configured for server: username, password, host type, address, etc. now, when i look at the folder im trying to connect to through IE, i can see it etc. and it says "port 80" at the bottom... so I put "80" in the "remote port" section, that is all gravy

now with my router, i open up my config, and open port 80 there to point to whatever computer I am sitting at's IP.

now back to this screen... any idea what I should be putting in these fields? I've tried using info for remote server, ive tried info for the router (account name and password, and the port to open, etc)
when i try to connect, it attempts (and does) connect to whatever server I placed in the top field of the "firewall" tab...

if i put router address, it connects, then times out and says "could not connect to (router address)
if i put remote server it connects, but then itimes out, and says "blocking call cancelled"

someone, please help me, for the love of...things :eek:
if i didnt include enough info for you to generate an answer... please, ask me... and I will spill it
 

Admiral Michael

Michaelsoft Systems CEO
#2
In your router forward port 80 (why not use 21) to the IP address if the computer with the FTP server. Now in WS_FTP under server put your WAN ip (Internet IP) if you want to connect locally, put the ip of the computer running the server here.

FOr the image, you have it correct, but if your connecting to a ftp server thats local then skip this, its over the internet (maybe at work) then you need to ask you system admin for these settings.

Hopwe this helps.
 
#3
Admiral Michael: This is not an FTP server, it's a client.
NerdUprising: That "Firewall" option is acctually about proxy. You don't have one of those. So in this case you're not using a "firewall".

You shouldn't need to do any kind of configuration to the WS_FTP client except to make sure it's using a passive connection (PASV) instead of active (PORT).
 
#4
thank you, Admiral Michael, Zedric - got everything sorted out on the client-side now...

when I talked to tech rep from my ISP about this, he said that it was possible too that they had not set my permissons yet... which now I think is the case, since it says that my password is wrong (...it is right, im positive) so now i have to call and complain again

but once more, thank you for your advice, it was most useful :D
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,962
Messages
673,240
Members
89,018
Latest member
timpage