• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Frustrating FTP connection problem

Heeter

Overclocked Like A Mother
#1
Hi Guys,

Well, after my ISP blocked port21. I was forced to move to another port. I am behind a Linksys befsr41 router. The problem is one of my family members is behind their own router and cannot connect to my FTP. My other family memeber has a straight to ISP connection and he gets through no problem.

We have tried everything, from me being in the DMZ zone of my router, to them clicking all the NAT/PASV settings on their FTPclient. We never had this situation when port21 was still available to me. I guess my router is configured properly for port21 for FTP, but not for any other ports.

I have tried a couple of sites as to figure out what to do, but it still doesn't work. I am using BulletProof ver2.15 as a server.

Is there something in my setup that I can accomodate other router connection? Maybe there is another router out there that I can purchase that will not have this connection issue?

Any help will be greatly appreciated.

Heeter
 

Maveric169

The Voices Talk to Me
#2
Well can anyone else connect to your FTP? I run BPFTP server myself for transfering files to my wife in CA, I am not behind a router but she is, and we have no problems.

I am sure you know that under "setup" ,"General" tab there is the setting to set what port your ftps is to listen on, so as long as that is set, and you have opened the same port in the router you should be good on your end. Might also want to check and make sure your set for a fixed IP under "multiple IP settings".
You might also check and make sure your firewall has that port open also, as if not it might be blocking the connection.

You will then have to check and make sure that the person who is trying to connect to your FTPS is "calling" on the correct port as well and that they are not being blocked via firewall and/or router.
 

X-Istence

*
Political User
#3
It is user error, no need to get a new router.

Just check all the settings are correct. I am running FTP on port 5000 with a linksys router, and it works just perfect.
 

Heeter

Overclocked Like A Mother
#4
From testing clients, it is confirmed that I can connect to server if I am not behind a router.

The problem is that anyone who is behind a router cannot connect to the server. We have tried all client settings, (NAT, PASV,etc) with no luck.

I think that should be able to configure something between the BPFTP server settings that will enable those with routers to connect to the server. The server is behind it's own router, as previously mentioned.

Thanks so far.

Heeter
 

ming

OSNN Advanced
#5
Not sure if you've checked the Applications and Games Tab in the Linksys configuration console. It should give you the option for Port Forwarding, which allows you to specify which Port should be opened to which application on a specific (internal) IP.
 

Heeter

Overclocked Like A Mother
#6
ming said:
Not sure if you've checked the Applications and Games Tab in the Linksys configuration console. It should give you the option for Port Forwarding, which allows you to specify which Port should be opened to which application on a specific (internal) IP.
The problem is not my router, it is the other person's router. My ports are forwarded already.

Heeter
 

Heeter

Overclocked Like A Mother
#7
X-Istence said:
It is user error, no need to get a new router.

Just check all the settings are correct. I am running FTP on port 5000 with a linksys router, and it works just perfect.
Was there any settings internally on the server software that you might be able to tell me that you did. (port range, etc.) The regular settings I have done already.


Heeter
 
#8
if you are going to have clients conenctiing to you with pasv - tyou need to map atleast 100 further ports to your pc and configure your ftp server to use them for passive IP connections.

for active FTP you need to open the port you want people to connect on and the port prior to it for connections to function correctly.

These problems are *rarely* a client side problem.
 

Heeter

Overclocked Like A Mother
#9
So if I understand you correctly, LordOfLA, If I forwarded port 2100 on router for FTP at present, then I should modify it to 2100 to 2200 on the router? Because right now I have forwarded ports 2099 to 2101 on my router with no luck.

As well, for my BPFTP server settings: The Passive Mode IP is set at my server's network IP address and enabled. But I do not know what to fill in for the "Passive Port Range" setting. Right now, there is 50125 to 50353. Does this make sense?

Thanks for all your guys's help so far.

Heeter
 
#10
Okay based on the details you just gave me:

Active ftp is port 2100 and passive ftp uses port range 50125 - 50353

so you should have the following ports mapped: 2099-2100 and 50125 - 50353 to your ftp pc.

set that up and get your friend to try again :)
 
#11
Didn't we go through this a few weeks ago?

Just follow the last post of LordOfLA and it should work, with one exception. 2099 isn't needed. So:
Forward 2100
Forward 50125 - 50353 (strange number of ports, but nevermind ;))
Keep 50125 - 50353 as pasv port setting in the server
Set the "Passive Mode IP" in the server to the external IP of your network. If it's dynamic, use a www.no-ip.com account and type that in instead.

There's a whole other way of doing this as well (never tried it myself) which explains why it worked before on port 21. There might be a setting in the router called "non-standard ftp port". Set this to 2100 and use the same settings as before. This should hopefully work as well.

Now choose one of the two methods above. Good luck!
 

Heeter

Overclocked Like A Mother
#12
Thanks Lord of LA, Zedric.

Yes, I couple of weeks ago, I couldn't get nothing into the FTP, now only routered computers cannot still get I am trying to around that.

I will try that right away.

Heeter
 

Johnny

.. Commodore ..
Political User
#13
You have to have the main port -1 forwarded. One is for the data and the other is for the connection. So if you are using port 2100 you have to also use 2000. Also the passive ports have to open passive +100 . So if 50125 is open you have to have it set up like 50125 - 50225 ..

I know some are going to say this is blarney, but every site I have been on and everyone I talked to are IT techs and work with ftp servers every day tell me the same thing i just told you. It is stupid yes, but it should work .. Good luck ..

And yes this was discussed a while back, but that was for port 21 not a higher port ...
 

Heeter

Overclocked Like A Mother
#15
Well LordofLA, Johnny and Zedric,

I have done exactly what was recommended, but to no avail, can a routered machine get into my FTP server.

At least now I am getting a different error come up on the client. I changed the server proggy passive ports to match my router forwarded ports. attached is what my router looks like now. I added one port above and below 2100 for safety's sake.

The error the I am logging is:

530 PORT command only accepts client IP address.

I am now officially lost.

Any ideas?

Thanks in advance,

Heeter
 

Attachments

Johnny

.. Commodore ..
Political User
#16
Heeter said:
Well LordofLA, Johnny and Zedric,

I have done exactly what was recommended, but to no avail, can a routered machine get into my FTP server.

At least now I am getting a different error come up on the client. I changed the server proggy passive ports to match my router forwarded ports. attached is what my router looks like now. I added one port above and below 2100 for safety's sake.

The error the I am logging is:

530 PORT command only accepts client IP address.

I am now officially lost.

Any ideas?

Thanks in advance,

Heeter
Check this site out: http://pctechforums.com/modules.php?name=FTP and this site http://www.linksysftp.org/index.php

and lordofla I meant 2099, I was typing faster than I was thinking ..
 

Heeter

Overclocked Like A Mother
#17
Well,

I have done exactly what this two sites have recommended, and I still get the same error on my server log as mentioned above.

I think that I am going to phone Linksys and see what they say. I don't know what to do anymore.

Heeter
 

Heeter

Overclocked Like A Mother
#18
Well, I talked to Linksys tech support. They told me that the client computers have to forward their ports as well. Something tells me that I don't believe him.

Oh well.

Heeter
 

j79zlr

Glaanies script monkey
Political User
#19
Johnny said:
You have to have the main port -1 forwarded. One is for the data and the other is for the connection. So if you are using port 2100 you have to also use 2000. Also the passive ports have to open passive +100 . So if 50125 is open you have to have it set up like 50125 - 50225 ..

I know some are going to say this is blarney, but every site I have been on and everyone I talked to are IT techs and work with ftp servers every day tell me the same thing i just told you. It is stupid yes, but it should work .. Good luck ..

And yes this was discussed a while back, but that was for port 21 not a higher port ...
You only need port 2100 forwarded along with a passive range equal to the number of concurrent connections you need. Port 20 is almost never used for DATA connections, when you have PASV enabled, the client connection is made with 21 and then the FTP server becomes the client, the problem with clients behind routers only exists if you are not using PASV mode. Your client is at error, he/she is using PORT not PASV mode, hence the 503 error. While forwarding 2099 might work, it isn't necessary as long as your CLIENT is using PASV mode.
 

Heeter

Overclocked Like A Mother
#20
But J,

enabling PASV mode on the client behind the router only gets stuck on PASV mode while logging in. Another error comes up 227 error. Either 530PORT or 227PASV. Don't know which one is worse.

oh well.

Heeter
 

Members online

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,013
Latest member
Pdawgintown