flash drive not workin


OSNN Addict
28 Dec 2005
I just bought a OCZ Rally2 1gb flash drive and when I brought it home and plugged it in the computer recognized the device but when I open My Computer I don't see anything to access the flash drive. The usb drives I know work so I'm guessing it may be the flash drive which just buying it is really frustrating. Please tell me I'm wrong lol.
try typing in the drive letter in the address bar....sometimes I get that issue as well
No that didn't work..

I'm fairly certain windows recognizes the flash drive. The taskbar recognized the new hardware and also has the icon "safely remove hardware" When I double click that and highlight "USB Mass Storage Device" and click "stop" one of the options listed is the OCZ flash drive I bought
most likely you have a drive grabbing the letter it wants. If you assign a mapped drive/optical/hard drive to the letter e for instance and the flash drive wants to grab that you wont see it.

go to control panel
administrative tools
computer management
disk managment.

and see if you see it in there. manually assign it a drive letter.
I tried that like twice, also rebooted after too and still stays the same. Which i check disk management again it was as if I never changed the drive letter at all still stays blank.

Also to note the flash drive can be found in device manager so for sure windows does recognize its there
Last edited:
gonna bring it to school tmrw to determine if its the flash drive or my comp that's the problem, up date later :nervous:
I'm not sure if this good news or not. I tried my flash drive at school and it worked perfectly fine. So I guess that determines it's my home computer...anyone have an idea on a fix?

EDIT: I already tried manually assigning a drive letter that wasn't already assigned, tried E and Z and this isn't "easy" *drum roll* lol...
Last edited:
Since I had no word from anyone here I tried contacting OCZ themselves, I had a lame attempt at them sending me a format.exe file for the drive but I've tried that before from their website and that didn't work since it doesnt' recognize the flash drive to be present in the first place. I told them it worked on other computers but all he gave me was an RMA solution. However I'd end up paying extra for a possible solution which seems absurd.

Just an update :lick:
Sorry dude, I am stumped.
It's the drive letter mapping for sure since you can see it in disk manager and it works on other machines.

Ugly but...
1) disconnect your optical drives and anything else taking up letter to make room for the thumb drive to be assigned where it wants.
2) Boot this way once long enough for it to be recognized.
3) Then change the drive letter to something near the end of the alphabet so it won't conflict. you might want to run that format program from OCZ while you have the drive recognized.

Now put your system back together and see if it still works.

Step by step instructions for changing drive letter:

Turn on boot from USB in your bios too and make sure your MB USB drivers are up to date.
Last edited:
I didn't really understand step 2 but after I changed the drive letter again i was able to run the format.exe file finally however still didn't see it in my computer or anything.

my bios doesn't have an option to boot from usb either

i updated my USB drivers, couldn't find it on the asrock website but i googled and found it. it re-recognized the flash drive again and did the "found new hardware" once again

EDIT: nevermind the "bios doesn't have an option to boot from usb" as well as Im unable to disable my A: from being listed in my computers...don't know if that's a problem or not, i did unplug it afterall
Last edited:
Sorry I'm throwing so many replies into my own thread but this thing is really giving me a headache. I tried unplugging my cd/rw (i dont have anything else) and the floppy drive, after i turned it on it said it needed somethign to boot from so i went into the bios and disabled it from checking the floppy drive

when i was able to get to windows, the floppy drive (a:) was still there in my computer however the cd/rw drive (D:) wasn't. I already had the flash drive plugged in and it didn't show up still in my computer.

went through the whole process of changing the drive letter (again) and after that i still didn't see anythign in my computer, however when i did the format.exe it worked but still couldn't access the drive unless i did it from disk management after the 2nd attempt (1st attempt doesn't work). i made the usb drive bootable in the bios after that and still didn't change anything, also re-installed the cd/rw and floppy drive

basically im still at square one....i might consider replacing the flash drive at the OCZ in canada if nothign still were to work

thanks again LeeJend for ur help but if u have any other ideas PLEASE let me know
Okay it's been a little bit but I'm here to update ONCE AGAIN:

Basically OCZ was of no help, I got no technical support at all just an RMA solution. So to hell with it I do the RMA. Just got it back today and it still doesn't work.

Now I'm fairly certain it's my computer since a) it works on NT, XP Home, and 2000. It's gotta be something w/ my drivers or something but I can't seem to figure it out. Drive letter assigning doesn't seem to be working and the USB drives work fine. Please help me! Don't wanna admit I wasted my cash on this thing :(
You implied that your machine is not running Home, NT or 2000 above.

What version of windows are you running, XP Pro or Corporate (about the same)?

Or is it Vista Beta or XP 64 BIT?

The only thing strange I can find about the Rally2 is it uses a dual channel memory architecture to make it faster. That should not affect how it is seen by windows though.

And it works fine on other computers?

Have you tried it in different USB ports on your machine? (Front back, etc.)

The next thing I'd do is downlaod one of the free Boot CD's that use Linux (Ubuntu, emergency Boot CD, austrumi, etc.). Burn the CD, set Bios to boot from CD first. That will run a different operating system from the CD without messing with your HD Windos install and you can make sure your hardware is working ok.
Last edited:
I'm running xp pro sp2. It works perfectly fine on other computers, i am unsure if it is an operating system issue yet or some other then that. i've tried different usb ports too and that hasn't worked.
Cause for concern:

I had my flash drive plugged in and then when I stopped the device so I can take it out safely, as soon as I took it out my computer restarted.
disregard previous post, i might've jus hit the reset button haha
but in other news, the flash drive works on xp pro just not mine :p

i might just have to reformat...
I got a fix for flash drive problems!!!

Reference: http://forum.osnn.net/showthread.php?goto=newpost&t=86226

I've had this problem for nearly 3 weeks. Above I posted the link to the problem I had. Thanks again to everyone who helped (didn't help me out but the thought was nice) after a lot of late night googling I got a fix to my problem and hope this helps people out in the future.

Summary of problem:
  • Flash drive usb 2.0 doesn't respond. Windows XP will recognize device and install it just fine but does not show up in My Computers.
  • Windows XP does not assign USB device a drive letter
  • When manually assigning a letter throguh Control Panel -> Admin. Tools -> Computer Management -> Disk Manager, no letter is initially attched to device.
  • After assigning a letter, right-click on the flash drive and click open it does nto work but a second attempt it does.
  • Still does not show up in My Computers
  • USB ports all work fine
  • Drivers are all up to date
  • Works on all other computers, had warranty replacement and still no good
Solution 1: Drive Letter assigning

First off, it usually is a drive letter problem. Sometimes with a mapped network, or some other related reasons when you plug in your usb flash drive it attempts to use a drive letter already being used.
Go to Control Panel -> Admin. Tools -> Computer Management -> Disk Manager. In the right pane you should see your flash drive. Right click on it and go to Change drive letter. Pick your letter like Z: and change it.

Solution 2: Windows XP has drive letters disabled

Probably pretty rare but easily fixable if the case. Not sure where I found the link but the file is: TweakUIPowertoy.exe, google it and you might find it. It's a tool from Microsoft that enables you to make various tweaks to XP. Install program and open it up. There go to My Computer in the left pane, Drives. You should see a list of letters available. If any letters are unchecked, check 'em. That's it.

Solution 3: The one that worked for me!!!

I had Daemon tools installed. Not sure what version I had but after much googled searches I found one regardin daemon tools. Something to do with the virtual drives I believe (just a guess) and usually with Daemon Tools version 4 (DT4). Uninstall Daemon Tools. You'll have to restart. Then search for these 3 files:
  • secdrv.sys
  • sptd.sys
  • sptd7021.sys (didn't find this one for me but you may find it)
Those are 3 drivers from daemon tools leftover after uninstallation. Delete them (backup if you wish) and restart.


Life makes sense again. I avoided a possible format and everything in life is good again. *PHEW* Hoep this helps someone!
I merged threads a bit :) is now just before you last post.

Members online

No members online now.

Latest profile posts

Also Hi EP and people. I found this place again while looking through a oooollllllldddd backup. I have filled over 10TB and was looking at my collection of antiques. Any bids on the 500Mhz Win 95 fix?
Any of the SP crew still out there?
Xie wrote on Electronic Punk's profile.
Impressed you have kept this alive this long EP! So many sites have come and gone. :(

Just did some crude math and I apparently joined almost 18yrs ago, how is that possible???
hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.

Forum statistics

Latest member