Error during windows boot

RyanK

OSNN Junior Addict
#1
Hello

Received the following on an old 98 machine I have at home.

"Insufficient memory to initialize windows. Quit one or more memory-resident programs or remove unnecessary utilities from your Config.sys and Autoexec.bat files, and restart your computer."

If you search the web, it says a lot about the memory but I have not touched this for a long time and it only has 128Mb installed anyway. The only change I have made to the machine recently is updating the ASPI driver. This was working fine for 1 week, then just tried to boot and got the above. I can still get into windows in safe mode after a reboot.

Any help really appreciated.

Ryan
 

Howling Wolf

We did not deserve this !
#2
The memory issue is system related and not hardware related, so it seems.

Indeed, as win98 is still partly Dos based, it loads several softwares (*.exe, *.bat,...) in the system memory (under 1Mb) via autoexec.bat and config.sys.
Cautiously, these 2 files should be modified so that some system memory is freed.
 
L

Lee

Guest
#3
RyanK said:
Hello

Received the following on an old 98 machine I have at home.

"Insufficient memory to initialize windows. Quit one or more memory-resident programs or remove unnecessary utilities from your Config.sys and Autoexec.bat files, and restart your computer."

If you search the web, it says a lot about the memory but I have not touched this for a long time and it only has 128Mb installed anyway. The only change I have made to the machine recently is updating the ASPI driver. This was working fine for 1 week, then just tried to boot and got the above. I can still get into windows in safe mode after a reboot.

Any help really appreciated.

Ryan
What version of Win98 is it?
 

loki

OSNN Junior Addict
#4
If you could post the contents of your autoexec.bat and config.sys here, i'll try to rewrite and save memory. I LOVED to do that back then :)
 

RyanK

OSNN Junior Addict
#5
Hi

Its 98SE, I will put a copy of the files on here tonite or early tomorrow. I have tried put a " ; " infront of the lines in the 2 files to stop them loading one by one so I could find the dogy line but no success.

I found some info on the microshaft website saying to modify the VCACHE line in the system.ini, is this wise??

Ryan
 

RyanK

OSNN Junior Addict
#6
ok, here is the config.sys
DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\WINDOWS\EMM386.EXE
rem TShoot: DEVICE=C:\CDPRO\VIDE-CDD.SYS /D:MSCD001
device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)
Country=044,850,C:\WINDOWS\COMMAND\country.sys

The autoexec.bat is just about the same so I will shkip that. I checked the VCACHE is system.ini and there was not any information in there!? I have entered some info in there and it made no difference so maybe I was barking up the wrong tree there!

Ryan
 
L

Lee

Guest
#7
Try installing the SE service pack from here if errors still persist then we can remedy it another way.

Looking at it, seems you might have a keyboard error.
 

RyanK

OSNN Junior Addict
#8
ok, thanks. I have downloaded the info, but need to get the CD drive working first, I'll have a pop at that and let you know!

Why do you think its a keyboard error? and where?

Ryan
 
L

Lee

Guest
#9
rem TShoot: DEVICE=C:\CDPRO\VIDE-CDD.SYS /D:MSCD001 sure that's a keyboard error I used to get on win98se
 

vivid_vibe

OSNN Senior Addict
#10
Lee said:
rem TShoot: DEVICE=C:\CDPRO\VIDE-CDD.SYS /D:MSCD001 sure that's a keyboard error I used to get on win98se
Hmm, if I'm not mistaken, since that line is rem'ed, isn't it being ignored anyway?
 

loki

OSNN Junior Addict
#12
RyanK said:
ok, here is the config.sys
DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\WINDOWS\EMM386.EXE
rem TShoot: DEVICE=C:\CDPRO\VIDE-CDD.SYS /D:MSCD001
device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)
Country=044,850,C:\WINDOWS\COMMAND\country.sys

The autoexec.bat is just about the same so I will shkip that. I checked the VCACHE is system.ini and there was not any information in there!? I have entered some info in there and it made no difference so maybe I was barking up the wrong tree there!

Ryan
OK try this as config.sys:

DOS=HIGH,UMB
DEVICE=C:\WINDOWS\HIMEM.SYS
FILESHIGH=40
BUFFERSHIGH=80
DEVICEHIGH=C:\WINDOWS\EMM386.EXE
DEVICEHIGH=C:\CDPRO\VIDE-CDD.SYS /D:MSCD001
device=C:\WINDOWS\COMMAND\display.sys con=(ega,,1)
Country=044,850,C:\WINDOWS\COMMAND\country.sys


The line that 'rem'-ed is indeed ignored. The rest of the line corresponds to a line in the autoexec.bat where you load the mscdex.exe driver for CDRom access. Your autoexec.bat cannot possibly be the same though, please post it here too. The keyboard config is in the autoexec.bat btw. Should read something like "keyb us".
Try the above config and see if it helps :)

good luck
 

RyanK

OSNN Junior Addict
#13
SUCcESS MY FRIENDS!!!!

I had to use a boot disk and run scanreg /fix, which rebuilt my knackered registry, then went into control panel / system and disabled virtual memory. Rebooted several times then eventually managed to turn it back on to replace the swap file.

I then installed the "unofficial Service Pack" and am now posting this message using the offending machine! I have also made the changes to the config.sys, so thanks for that!
For consistency here is the Autoexec.bat file;

mode con codepage prepare=((850) C:\WINDOWS\COMMAND\ega.cpi)
mode con codepage select=850
keyb uk,,C:\WINDOWS\COMMAND\keyboard.sys

PATH=%PATH%;"C:\Program Files\Mts"
C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MSCD001 /V

It looks particularly messy, so if you have any idea how to re-do the "PATH=%" part, feel free!!!

Thanks

Ryan
 

loki

OSNN Junior Addict
#16
RyanK said:
SUCcESS MY FRIENDS!!!!

I had to use a boot disk and run scanreg /fix, which rebuilt my knackered registry, then went into control panel / system and disabled virtual memory. Rebooted several times then eventually managed to turn it back on to replace the swap file.

I then installed the "unofficial Service Pack" and am now posting this message using the offending machine! I have also made the changes to the config.sys, so thanks for that!
For consistency here is the Autoexec.bat file;

mode con codepage prepare=((850) C:\WINDOWS\COMMAND\ega.cpi)
mode con codepage select=850
keyb uk,,C:\WINDOWS\COMMAND\keyboard.sys

PATH=%PATH%;"C:\Program Files\Mts"
C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MSCD001 /V

It looks particularly messy, so if you have any idea how to re-do the "PATH=%" part, feel free!!!

Thanks

Ryan

First of all: congrats for fixing your machine! Yeah the stupid scanreg...didn't think of that one :)
Since we already are at optimizing startup files, try this as autoexec.bat:

PATH="C:\Program Files\Mts"
mode con codepage prepare=((850) C:\WINDOWS\COMMAND\ega.cpi)
mode con codepage select=850
lh keyb uk,,C:\WINDOWS\COMMAND\keyboard.sys
lh C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MSCD001 /V
The 'lh's should load the corresponding programs (keyb and mscdex) into the upper memory block. This will have a repercussion on your available conventional memory (run 'mem' in dos mode to have a look). The more KBs free towards the theoretical maximum of 640KBs, the better :) I know there are more possible tweaks (e.g. STACKS in config.sys), but what the hell :)
Have a nice day. Hope this helped a bit.
 

RyanK

OSNN Junior Addict
#17
Thanks For your help.

I have updated the autoexec file and it is running great! One last question, what is the PATH="C:\Program Files\Mts"
I have checked for this directory on the machine, but it is not there! Can it be removed?
 

loki

OSNN Junior Addict
#18
Ah yes then it can be removed. The PATH variable defines the directories (now called folders hehe) from which commands can be run in DOS Mode or in the DOS Box without requiring the user to 'be' in that directory. For example, if your PATH variable looks like this:

PATH=C:\DOS

then you can run any command in the C:\DOS directory even if you are in C:\TEMP, meaning if your command line looks like:

C:\TEMP>

To be more specific, if you have a program called bingo.exe in C:\DOS (Filename: C:\DOS\BINGO.EXE) and you type 'bingo' while staying in C:\TEMP (looks like C:\TEMP>bingo) then it will work.

The PATH variable is very helpful when it comes to work in DOS. For example, if you set your path like:

PATH=C:\DOS;C:\WINDOWS;C:\WINDOWS\COMMAND

then you should have all the MSDOS programs at hand without having to remember each program's location on your harddrive. Just type the command and go :)

Please note that the PATH variable is set only at boot time and if you run autoexec.bat manually (remember that in this case you also reload every program loaded at startup, thus losing precious RAM.)

Hope this helps a bit

(Oh dear I really miss my DOS hehe)

Bye bye
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,970
Messages
673,297
Members
89,017
Latest member
Poseeut