DVD R/W just disappeared!


Debiant by way of Ubuntu
Hey, this has happened on my new AMD64 rig within the last 48-96 hours or so.... my master on the IDE1 channel, which is an NEC DVD R/W... has disappeared, at least from within XP....

Now I know it was there when I built my rig, because I would play DVD's in either player (slave is a SONY CD/DVDR).... and I am about to go to BIOS to autodetect, see if that works.

My question to you guys is what next if that does not work - also what caused it to get "lost"?

I have had this before on an old Duron and it was eventually only resolved by physically unplugging, rebooting, then replugging the drive and rebooting - and Voila - drive was found again as new hardware.....

Who thinks that is what I will have to do here? :confused:


Modding Addict
Political User
i think that's what you should do. it's happened to me before. also make sure the jumper on th drive is manually set to master. windows like to mess **** up it you let it.


Debiant by way of Ubuntu
Yeah Taggert - looks like you are right, because I just got back from a BIOS boot and without even having to autodetect the NEC DD R/W was right there as master on IDE1....

weird that it is still absent from Windows - anyway, now I have to shut down and reboot twice and cross my fingers that it reappears....


Debiant by way of Ubuntu
UH oh :eek: just rebooted without and then again with - still no DVD R/W!

this is driving me nuts - since is there in BIOS!

BUT - I have a clue - there is still a removeable drive showing from when I tested a flash drive on this machine..... now how to get rid of that properly (and yes I did do a safe to remove click on the systray when I unplugged!)....

Off I toddle to device manager and admin tools - any hints still gratefully received! :\ :cool:

[EDIT] aha - it is showing, but as a removeable drive which is also unreadable (according to admin tools) so now the question is how do I get it back to a regular optical drive? At the moment I cannot even assign it the drive letter I want, it has defaulted to G.... BTW I think it was probably like this even before I unplugged and replugged it.... surely someone else has had this and can help? :confused: [/EDIT]


Modding Addict
Political User
when i installed another cd drive in my comp last month i had lost both drives in windows and yet the manin drive showed up in the bios. so i ahd reset both jumpers on the drive as master and slave. try the jumper settings on the drive and remove all drives displayed in the device manager except the hdd obviously, and see if that works. sometimes you have to manually set the status of the drive, because windows does it one way when your bios has it set another. or so i think. setting the jumpers fixed my problem. might fix yours.


Debiant by way of Ubuntu
ARGGGggghhh! I thought I had found a way for a moment, I ran the windows uninstall for the device - rebooted - it found a new drive and advised to reboot for it to work properly.... But once again it has reinstalled it as a removeable storage device which is unuseable (drive G) just as it was to start with.

I know the jumpers are fine (and infact that this is Master!) because everything was fine when I put it all together. Somehow it just cannot put the "new" DVD/R in right again! Anyone help? I really cannot face a reformat - it took me about a month to get this rig sorted with it's SATA boot drive and right now DriveImage is failing on me, so I cannot even take an image to restore on top of a reformat (and if I do chances are this problem could come back at me anyway).....

So I really need to solve this! Otherwise I'll never burn that Linux DVD and get a crack at SuSE - never mind other longer term plans for burning DVD's! :(


Debiant by way of Ubuntu
Not sure I can follow fully the tortuous steps that were tried - only one precise sequence worked and even then after further work on the rig the drive eventually reverted to its useless original state (IE the problem reasserted itself).

I think the step that worked was to boot with the DVD drive alone and then add CD drive (in fact "hot plugging" it, not sure if that is required though).... Following that a reboot was needed to add the CD drive as well as the DVD (HW wiz could not find it).

Then all was well and restore point set and then I went to reinstall drivers for a Leadtek Winfast TV Expert PCI card that got lost in a Restore to the weekend.... then all was still OK for a while - then I went to the Leadtek site for the latest drivers for the card - installed them - needs a reboot - this time on reboot a couple of things happen.....

Machine hangs on post at the processor ID stage (I know this from diagnostic U thingie I get with my MSI card that shows four LEDs) - so I have to hit reset.....

Reset allows post OK and boots to windows BUT the DVD drive has become unuseable removeable media again.....

Anyonw have any further steps to try or knowledge to impart? I neither want to flash any firmware nor reformat... anything else I will try.

The next step I see for myself is to get DVD back and reassign it's drive letter from V (as I have it now) to G (which is the letter Windoze gives it when it "loses" it)

Any thought - as always - welcome...


- geek -
If the drive is still showing in device manager couldn't you just unistall it and let windows reinstall it. Then when it does set the drive letter on it so that when you use your flash drive again it won't be able to steal the drive letter. :) I had to do that with my DVD+RW and DVD drive when using USB drive(s).


Debiant by way of Ubuntu
I have almost done like Xie says.... went throught he same sequence and assigned the G drive to be my DVD (instead of V like I had it)....

Now just have to see if problem comes back at me on rebooting ever.... Might just reboot now, best to know ahead of time...

Thanks Hipster - but I am not sure it is a driver problem (although I will bear it in mind to try if problem comes back at me).

Also I think the flash drive was innocent..... somehow the DVD drive is maybe getting a driver as if it was one though - so I shal surely be paying a visit to the NEC support pages as/when/if necessary!

I'll post back what happens after reboot - but right now going to check a Linux install on the other machine plugged to this monitor....


Modding Addict
Political User
This tweak will restore the missing drives after a reboot.

[Start] [Run] [Regedit]
Registry Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class
Key Name: {4D36E965-E325-11CE-BFC1-08002BE10318}
Value Data: [Delete All Value Data from UpperFilters and LowerFilters]
Note: Do not delete the Key or the Multi-String Values. Delete only the data values.
Exit Registry and Reboot


Dabba Dooba
Political User
hope everything works out.

also u are doing what i do. I have my main computer on and usually have my other computer on but both use my monitor cause i am poor to buy another one. I was running off an extension cord but having 2 computers on sometimes ,speakers, phone and a monitor always on i figured that i shouldnt be doing that anymore.


Debiant by way of Ubuntu
OMG!!! :eek: I did - looked like machine went a bit screwy after, had a message for failing to locate drivers..... then this morning I power back up... the DVD actually looks like it may be there, unlike the night before when the tweak had not helped.

BUT :eek: I have no mouse or keyboard! I mean they will like work before XP but not in Windoze.... so it is an XP problem....

So far I have tried:-

Last known good config.
Safe Mode
Booting to XP disc

The last is the one that really scares me - because even though I load my SATA drivers it will not recognise that I have a windows installation on the SATA drive I have made drive C! :eek:

Can anyone help? I no longer care about my DVD drive - my whole windoze installation looks like it could get lost - and it took me a LOOooooong time to get that SATA to be my boot drive!

I shall make a new thread - this problem had changed completely.....


Double O Egghead
I recently had the same prooblem as yours

I know about the upper and lower fix but this time it does not help and the problem is deeper.
I have been experimenting with trojans and one has a feature to hide the cd-roms

not sure if I somehow jinxed my windows but every known cure could not repair the problem

For your info...

repair install of windows still resulted in yellow exclamation mark for cd drives in device manager

only cure was to delete the current installation

no one on the net could get me out of this one.....

keep trying


Debiant by way of Ubuntu
I fixed that and then this!

Yeah thanks EggHead - I find myself in the same exact situation ....

Could you confirm if the upper/lower registry fix was benign (IE did no harm) for your situation?

The reason I ask is covered in this thread which will show you how I have fetched up just where you did - facing the long boring road of a reformat (again!)....

these things are sent to try us?


Debiant by way of Ubuntu
:eek: Reformatted - and on the first screen I get to with the BLISS wallpaper - guess what? The freaking DVD drive is down as removeable media with issues! So even a reformat fixes nothing!

And to add to this I just had to reboot the thing after installing mobo drivers - and guess what - it booted to the old SATA drive, and again no mouse nor keyboard..... (Windows refused to allow me to install to the SATA drive, I think to do that I am forced to unplug the IDE drives or something - suffering problem fatigue here and starrting to stop caring).

So I am about to go back and press the reset and try F11 hoping I get a choice of where to boot.....


Debiant by way of Ubuntu
incredible - after a very very long and troublesome process during which I lost the k/b and mouse (another thread) I manage to restore to the 23rd November, it looks like the DVD drive is there OK - then I try to put back the drivers for my Leadtek Winfast card and (as has hapenned before) there is one hang and then one unwanted reboot during install (which does not complete OK) and now lo and behold the DVD drive has gone AWOL again and become removeable/unuseable media.....

I'm off to look into Leadtek/Winfast forums - must be something with that card somehow....


Debiant by way of Ubuntu
Bump - still trying to track this down, anyone else had this with a Winfast card? Or anyone had the "removeable media" syndrome that renders a DVD/optical drive useless?

Right now I am faced with the ludicrous situation that if I wanted to burn a DVD or use both optical drives I have to open case and unplug CD, reboot, and still put up with it going AWOL again in the future.... I'll post here if I make any progress, but right now I am locking down a backup to try to expedite recovery if things screw up worse again....

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member