• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Dual Boot with XP / Vista Problem


OSNN Junior Addict
OK this is the deal. I have a C: HD with one big partition with XP Pro that I've always used. I recently got a 120GB HD and broke it up into three partitions. On one of those I installed XP again and currently using it as my primary OS (D: ). On E: I installed Vista. When I reboot first I get a dual boot screen for either Vista or Legacy (XP) OS, after that I get another boot screen for which XP Pro to boot into. I reformated the Vista partition cause I no longer wanted it. I still get the Vista / Legacy dual boot screen. I DO NOT want this, I want it to go away. I deleted that entry out of my boot.ini but it's not working, I still get the screen. Can someone please help me.
Last edited:


OSNN Junior Addict
This was a really strange problem. What happend was Vista has a different boot loader then NT/XP. So it created a \boot folder and a bootsect file on my C: drive. What I did was deleted that boot folder and the file, as well as my boot.ini folder. That fixed the Vista dual boot screen during boot up. Now it's back to normal, the only dual boot screen that shows up is for my XP partition on my C: drive and XP partition on my D: drive. The only problem now is that under those two choices I have an option for "Windows (default)" which will automatically boot into my C:, but from this point forward I want to boot into my D:. But it's just a matter of hitting the up arrow twice and hitting enter so I don't mind. Just glad I got that Vista screen out of the way.


█▄█ ▀█▄ █
Political User
That's not all that surprising, different Operating Systems, especially newer ones, tend to have different boot loaders.

Regardless, glad you got it sorted :)

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member