driver help with x64

IDLE

OSNN Senior Addict
Joined
Feb 13, 2004
Messages
375
#1
i have a asus k8n nforce3 mobo that i am trying to find the damn x64 drivers for it. i have tried asus old ass drivers (which worked on the beta) and i have tried nvidias drivers as well and i am coming up short. all this crap worked on the beta. what the hell did they do to this?
 

IDLE

OSNN Senior Addict
Joined
Feb 13, 2004
Messages
375
#2
called Asus and this mobo is not supported under windows Vista. im a little pissed off. they do not have any drivers for this model. they had beta drivers on this mobo during the beta of Vista. i am uber pissed
 

IDLE

OSNN Senior Addict
Joined
Feb 13, 2004
Messages
375
#5
well after removing the network controller from the list in device manger and reinstalled the drivers from nvidias site. i am now connected. thanks for the help Sinister
 

IDLE

OSNN Senior Addict
Joined
Feb 13, 2004
Messages
375
#6
welp, rebooted and now they dont work. retried the same process to reinstall them and now it doesnt work. stupid OS
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,979
Messages
673,325
Members
89,020
Latest member
Amanda99