DMA Gone!!!!

M

Mr Dead

Guest
#1
My dvd rom has been working fine in DMA mode, but recently I tried to rip a dvd that was badly scratched. This then caused several read errors and now windows has locked the drive in PIO mode. I have had this prob before and was forced to physicaly swap the drives around to get DMA up and running again.

Are there any registry entries I can delete/modify to get it to run in DMA again.

p.s. ive tried the IDE tool from the via website sorted the prob but for some reason my pioneer A03 and Liteon 12101B wont burn any disks even though the system seems to think they are, the "burning" lights dont come on and the disks remain blank after the operation.
 
E

ehornsey

Guest
#3
One other reason

There's one other reason why your CD drive was once DMA and now PIO. Which is probably the most annoying feature of XP.

If XP determines that it has had too many errors with that device. It will then step back the transfer mode all the way back to PIO mode. I am not aware of any way to put the device back to DMA.

Look at this Microsoft Article under repeated DMA errors

Microsoft DMA
 
M

Mr Dead

Guest
#4
Had to do it again, switched the drives master/slave settings to get DMA mode running on both drives again. Someone out there must know a reg hack or have a prog so you dont need to do this.

p.s. uninstalling the device and everything else just doesnt work in windows, so physically changing the drives is the only option unless someone else out there knows different!!!!
 
E

ehornsey

Guest
#5
Flashing the BIOS of your CD Drive will cause the new hardware wizard to start and reset the DMA error count.
 
M

Mr Dead

Guest
#6
Good idea!!! never thought of that, as long as I can back flash I can just swap between 2 firmwares whenever the prob re-occurs!!
 
X

XP Abuser

Guest
#7
hi all! try opening device manager look for IDE/ATA controllers go to secondary IDE channel im assuming thats wat your drive is on right click properties bust over to advanced settngs and change PIO to DMA ! should fix it
 
E

ehornsey

Guest
#10
I've been looking on Google news. This problem seems to hamper a few ppl repeatedly. They have suggested removing the Secondary & Primary IDE controller and rebooting XP. My view is this is a bit drastic but the comments say it works.

The only device afflicted with this problem on my system is a LiteOn DVD reader 163 model. Its a slave on the secondary channel.

I also saw some registry keys

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11
CE-BFC1-08002BE10318}\0001]
"DmaDetectionLevel"=dword:00000002

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11
CE-BFC1-08002BE10318}\0002]
"DmaDetectionLevel"=dword:00000002

I havent checked these at all. But judging from the dword value it seems to be forcing DMA detection.

Gotta say I'm disappointed with XP, as W2K on exactly the same hw works a treat.
 

BonyTony

OSNN Senior Addict
#11
This should fix it...adiing more to last post worked for me !

Open REGEDIT and find the following keys:

HKEY_LOCAL_MACHINE\SYSTEM\curr
entcontrolset\control\class\ {4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

Last four digits are likely 0001, 0002. Under those keys you will find MasterIDdataChecksum, SlaveIddataChecksum. Delete the value corrosponding to your drive by right clicking on the master and slave checksums and then choose modify and delete the value data box contents do this to both 0001 and 0002 lines.
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,971
Messages
673,299
Members
89,017
Latest member
soperyzoity