• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

dead onboard NIC?

mooo

thecyberninja
#1
I was looking at my brothers computer. He has a Dell dimension (if i am not mistaken) and it doesn't recieve anything from networks when its set to DHCP. when I ipconfig, the 169..... comes up which i am guessing is some default of "you are screwed", he is running windowsXP pro so i deleted the device from the computer, rebooted, did network wizard and it still did not work.

He has another box and his laptop on the network and they are working fine, bot recieve an IP and can share. Any ideas on what could cause this or a way to fix?
 

kcnychief

█▄█ ▀█▄ █
Political User
#2
Well, the 169.x.x.x address is utilized by what is call APIPA (Automatic Private IP Addressing, i think). This means that it can communicate internally with other computers on the 169.x.x.x range, but not out on the internet. Believe it or not, I have seen some areas that use that technology for maximum security when only internal traffic is required.

Anywho, it may be something to do with the TCP/IP stack. When you try to do a ipconfig /release and ipconfig /renew, do you receive any errors? Try running WinsockXPFix, which may solve your issue. Free download, can be found here:
http://www.snapfiles.com/get/winsockxpfix.html

Of course, it may be a bad NIC, but that is something to try.

Good luck :)
 

mooo

thecyberninja
#3
It says its not set to DHCP or what ever that error is (but the card is actually set). I will give that a shot and buy el cheap-o NIC i guess if it doesn't work. 10/100 should be fine for him and they are only a few bones now a days.
 

kcnychief

█▄█ ▀█▄ █
Political User
#4
Depends on where you get them. Most stores near me cost at 19-29 bucks for a 10/100 NIC, mostly because the market is smaller for them these days.

Have you ensured that DHCP is actually set, and that there isn't an alternative configuration setup as a fail-safe?
 

mooo

thecyberninja
#5
Well when i deleted it and reinstalled, I set the tcp/ip properties to dhcp, and then rechecked are the reboot and it was correct. And still nothing on ipconfig & ipconfig /release. The only thing installed for the NIC in the actual prot. are the basic for windowsXP so I am guessing nothing is bothering it. I only spent about 20minutes into looking at it and then just said the hell with it for the night and went bowling :) Thinking I would rather give him a $10 NIC and tell him to quit messing things up :p 1hour of looking into it is worth more than $10 to me. I could be watching quality TV or playing on osnn

I have a really good store on my way home from work ( www.microcenter.com ) they have great prices and have a selection like compusa.
 

kcnychief

█▄█ ▀█▄ █
Political User
#6
Cool, well good luck.

I agree that too much time is excessive, especially when the hardware could be at fault :)

Let us know how it works out.
 

mooo

thecyberninja
#8
yea i tried static and it didn't work..
BUT kcnychief, that program worked like a charm. I don't even know what it did it happened so fast and it was fixed. thanks bro :) that file is saved for the archive
 

kcnychief

█▄█ ▀█▄ █
Political User
#9
No problem, glad it worked.

Just as a reference, if you are using Windows XP SP2, Click Start, then Run and type CMD in the dialogue box that appears, and then click OK. Type netsh winsock reset into the DOS window that appears.

That essentially does the same thing, but the tool you downloaded is easier ;)
 

Members online

No members online now.

Latest posts

Latest profile posts

Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,015
Latest member
evaiwhitis