DCC send in IRC on an XP LAN (cant .... :( )

S

SkunkMonkey

Guest
ello

I use mIRC 5.91 on a 2 PC Lan with crossed cable (both running XP) sharing a cable connection.

I cant send files from mIRC (or any other, for that matter.) I'm told it's a firewall problem, but aint any the wiser. (I'm on client machine....host machine can send no probs)

I'm told this is the place to go for correct, fast answers.

Any help would induce lots of humping, probably.... :D


Ta d00ds
 
Z

zman

Guest
DCC in mirc behind a gatweay = pain in the ass :)

what you need to do is MAP ports to allow the client to pass through the gateway....

In MIRC DCC options

you will see DCC ports : start 1024 and last 5000

Reduce them to say

start 1024

last 1027

Now map them ports 1024 -1027 to the client machines IP address

Note : Punching a hole through NAT may be a security risk.
 
S

SkunkMonkey

Guest
Map the ports, map the ports...how does one do that?

And how much of a security risk is this gonna cause? As much as i'd like this to work, i dont want port party at mine :/

Cheers man
 

Akash

OSNN Senior Addict
Joined
2 Dec 2001
Messages
350
i cant seem to dcc full stop!
recieve is fine
sending i cant
weird :)
i would say mapping but imon ICS and also that the host cant send either

ah well :)
 

JJB6486

Retired Mod
Political Access
Joined
3 Dec 2001
Messages
1,207
You have to map a specific range of ports. If your gateway machine is XP, the port mapping is built in. If the gateway is 98/ME, use the tool at Practically Networked. Read the "readme" at the top of the forum. There is a link there to a guide on ICS. It will answer all your questions

JJB6486
 
X

Xtrecate

Guest
re

If you (or anyone else) is behind a Cisco 67x series DSL modem/router, then you need to add nat entries to allow mIRC to send stuff via DCC.

Once you are telneted into the router, and are at enable level (type 'en' once at cbos prompt, and enter password)

set nat entry add YOUR_INTERNAL_IP 1024-1027 * 1024-1027 tcp

(YOUR_INTERNAL_IP will probably appear as 10.0.0.* or 192.168.0.*)

This also works for udp ports, which is used by ICQ for some features. Just replace the port range with whatever you want, and replace 'tcp' with 'udp'

(i.e. set nat entry add YOUR_INTERNAL_IP 10000-12000 * 10000-12000 udp)

If you are sure that no one else on your LAN will need any sort of specific port access (or your pretty confident that they will never figure out what you did :D.....) than you can go ahead and every port you could want. This has some security risks, as it puts all the firewalling responsibilities on the client machine, which isnt always taht big of deal.....

Use two commands to do it:

'set nat entry add YOUR_INTERNAL_IP 7-65000 * 7-65000 tcp'
then
'set nat entry add YOUR_INTERNAL_IP 7-65000 * 7-65000 udp'
then
'write'
and finally
'reboot'

voila....your servers work, and so does mirc, icq, and everything else.

Hopefully that helps u DSL router owners out a bit.
 

Members online

No members online now.

Latest profile posts

Xie wrote on Electronic Punk's profile.
Impressed you have kept this alive this long EP! So many sites have come and gone. :(

Just did some crude math and I apparently joined almost 18yrs ago, how is that possible???
hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?

Forum statistics

Threads
62,004
Messages
673,460
Members
5,599
Latest member
Larry Chris