cmd commands not working?


Status:In Post-Production
I have been trying to launch various cmd commands, but none of them are working.

A while back I used the 'convert.exe' option to change a USB drive from FAT to NTFS.

I typed 'convert X: /fs:ntfs' and it worked fine -- I've done that before. (X represents variable drive letter)
Now I am trying to do the same thing, but it is saying "'convert' is not recognized as an internal or external command, operable program, or batch file".

It dawned on me that it was doing the same thing when I was trying unsuccessfully to launch apktool.

So I decided to go more basic than that. I did a simple "ping" and I got the same error.

Why are my cmd commands not working?

Operating System
Windows 7 Ultimate (x64) Service Pack 1 (build 7601)

3.20 gigahertz Intel Core i5-3470
128 kilobyte primary memory cache
1024 kilobyte secondary memory cache
6144 kilobyte tertiary memory cache
64-bit ready
Multi-core (4 total)
Not hyper-threaded

Gigabyte Technology Co., Ltd. H77M-D3H
Bus Clock: 100 megahertz
BIOS: American Megatrends Inc. F5 03/29/2012

Slot 'ChannelB-DIMM0' has 8192 MB

NVIDIA GeForce GTX 660 [Display adapter]
Samsung SyncMaster [Monitor] (24.0"vis, s/n YCUYHVDZ702086, July 2010)

NVIDIA High Definition Audio
VIA High Definition Audio


Just Floating Along
Staff member
Folding Team
Political User
Just a stab in the dark, but have you checked that 1) The actual exe files exist (ping.exe and convert.exe are both in the c:\windows\system32 or c:\windows\SysWOW64 directories) and 2) that your environment variable for your path is including those directories.