Can't play any Direct3d Games, pls help..


OSNN Junior Addict
7 Jan 2004
I can play every opengl game going, but an direct3d like cnc generals etc just minimises on load and wont maximise. I have tried catalysts 3.10's and 4.10's. Any ideas?
You tried running dxdiag from the Start>>Run?
It should tell you if anything's up. ;)
Yeah it says its fine, but wont run the Direct3d test. I have re installed dx9b and upon rebooting it works perfect. But then the next reboot it goes back to none of my games working, this is definately some rogue reg key doing something. Anybody any idea?

Btw when i try running the direct3d test it says, it was cancelled because I pressed a key. When i didnt, still does it with no keyboard plugged in.
had the exact same problem, also got the same error when running the tests. never figured out how to fix it, but the weirdest things was that after installing a game from microsoft (it was something with titans, rts game), the install did something to my pc (probably something with directx) and after that it worked.

Members online

No members online now.

Latest profile posts

Also Hi EP and people. I found this place again while looking through a oooollllllldddd backup. I have filled over 10TB and was looking at my collection of antiques. Any bids on the 500Mhz Win 95 fix?
Any of the SP crew still out there?
Xie wrote on Electronic Punk's profile.
Impressed you have kept this alive this long EP! So many sites have come and gone. :(

Just did some crude math and I apparently joined almost 18yrs ago, how is that possible???
hello peeps... is been some time since i last came here.
Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.

Forum statistics

Latest member