• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

can't get new php/mysql install to work.

Heeter

Overclocked Like A Mother
#1
Hey all,

I am trying to figure out how to fix my php/mysql install.

Here is the scoop:

I transferred my Windows 2003 Server web setup onto new hardware. It is a fresh clean bare metal install of, consisting of all updated apps, like Apache 2.2.8, PHP5.2.5, and MySQL 5.0.51a

Now I got APache and PHP and Mysql installed and restored my sql databases. Everything is working except for PHP is not connecting to MySQL

I checked my windows path to make sure my C:\PHP is there.

I think that Imight be needing some fresh mysql dll extensions for php. I am reusing the mysql 4.0 dll's that I had from previous install. I also noticd that the php.ini is slightly diffferent from previous as well. All the commented out extensions are gone.

How do I get PHP to communicate with Mysql?

Thanks,


Heeter
 

Dark Atheist

Moderator
Staff member
Political User
#2
first off you cant use mysql dlls from 4.0 on 5.0.51a, you have to use the dlls that come with the version of mysql you are using, copy libmysql.dll (think thats it) from the bin folder and either put it in c:\php or c:\windows, i also tend to put php.ini in there as well
 

Heeter

Overclocked Like A Mother
#3
Thanks, I upgraded the mysql.dll

I downloaded all pecl folders and extracted them into the /ext folder.

I copied the lib...dll file into several C:/Windows folders, system32, system, Windows folders.

I have rebooted the dam server several times.

Still getting same error: http://www.hcctech.ca/phpmyadmin


Heeter
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,960
Messages
673,237
Members
89,011
Latest member
grovo_test