• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Cant delete certain files!



Sometimes, with certain files, when I try to delete them, I get an error saying

Cannot delete this file.xxx: It is being used by another person or program. Close any programs that might be using this file and try again.

But there are no programs running that could possibly have it in use (i checked the ctrl-alt-del processes) and theres no one try to get it over the network, cuz im not connected to it atm. and theyre not some system file or smth, its music and video files

So i reboot, and I STILL get the same errors on the same files

this is really bugging me


I am having the same problem, mostly with files I download from IRC. I've found that I have to right click, go to properties and uncheck archive, then it lets me delete or move the file. Sometimes this doesn't work though.

XP is cool but there are some stupid bugs that just don't make any sense. Oh well.


Looks like a sharing violation. Sometimes naughty programs or ones that crash keep things loaded in memory and windows prevents these files from being deleted. A reboot will cure this, or sometimes running the program that you are trying to remove then closing it properly.

If it's a file on a network drive, reconnect it and try again.



OSNN Senior Addict
same prob here too
it used to happen on 2k too.
Do this, ctrl+alt+del and end task explorer
then file>run>explorer.exe
then try and delete it
bam! its gone
its weird.... for me this could happen if i just change its readonly options or say if i copied a file from one folder to another and wanted to then delete the original folder.
its stupid, and annoying as hell
and itshappening much more in XP than it used to in 2k.


restart in safe mode with command prompt, then goto the files u wana del then delete them

DEL "filename"


I'm also having the same problem, it's dead annoying. I can't rename certain files (I think it's incomplete downloaded files that are the problem). All my folders (on both my FAT32 C: and NTFS D: and E:) are greyed in the read-only section of properties, and even if I remove this, they just appear next time I do properties. Sometimes viewing the properties of the file I'm trying to rename will fix the problem temporarily, and I can rename the file after, but only sometimes, and I'm not sure why it works. I would really appreciate it if someone could help me out with this. I only have one user profile on the computer as well, so I don't think sharing should be a problem (although I did upgrade from Win2k, so maybe it doesn't think I have the proper priviliges)?



Sharing is the problem. Sharing is not in reference to multiple users using the machine at the same time.

Each file you open on your computer will be "locked" so that it can't be deleted when in use (this results in the sharing violation error when you try to delete a program that you have running - the files the program uses are in memory and hence protected from deletion). If you run a program and it crashes, it will sometimes not relinquish the lock it has on the file - net result: a sharing violation as the program/dll is still in memory and marked as locked. This is why reboots fix the problem as the file is not loaded or locked upon boot.

Performing some operations on the file(s) in question might break the lock - such as reloading and exiting the program gracefully. Sometimes the lock will be broken by another program.

In general, if you are getting sharing violations you are trying to do something which the machine believes is bad. If a reboot fixes it - don't worry. Just don't run programs which crash :D



Argh the problem is - the application hasn't crashed, and rebooting doesn't fix it :(. Quitting the program and restarting it etc. doesn't seem to have an effect either. Who knows what Windows is up to. I might just convert it to FAT32 and hope that that sorts it out.



I had the same problem, I used "end it all", a small application that shuts off everything open on your computer (except those you don't want to). Also, you could turn off some stuff that load at boot with msconfig.exe, or use selective booting in msconfig.exe.


im the one who started this post :)

ive tried all ways described on this post to resolve it, none have worked...sometimes i get lucky and i can del them, the files are all .avi in divx format from tv shows ive captured on my card...so once i burn em or decide i dont want them, they wont delete or rename, its taking up lots of space but mainly it annoys the hell out of me!

a way if i want to del them is i open up another avi file in virtual dub, and select direct-stream copy and save it as the file i want to delete, it gives me a stream copy error (most likely due to the same problem that makes me not be able to del it)

after that, the avi file is now 0 bytes in size, no more space to worry about it taking up, and the next time i reboot i can delete it

sometimes i have to modify the fps on them to get the audio synched up, so i have about 5 files by the time i get it right! thats 5x the original size, and on hour long shows that can get up to about 1gb in size, doing what i just said helps keep the size down

but when im down, i still cant rename/move/delete it!


I had the same problem and did everything to delete the file finally I just took another file renamed it the exactly like the file I was trying to delete and dragged it into the folder of the file I wanted to delete, it asked me if I wanted to replace the file, I said yes and that was it. Just deleted the new file and everything was fine. I was very annoying!! I hope this works for you because i tried everything else.


Ok guys I think this is what it is! I've had the exact same problem with DIVX .avi files and I have concluded that the reason it does this is because the file is not complete or it 'thinks' the file is not complete so it therefor checks through the whole file looking/analysing 'something' until it gets to the end. This happens when you just click on the file once and you'll see the HD light flashing continuosly all the way through. The only way I can rename the file is to right click then go to properties, this will bring up the properties box in about 10 minutes LOL :) when xp has finished doing its crap. Meanwhile have the filename highlighted and change the name but do not press enter. When the properties box comes up 10 mins later then it would have been renamed. I know this doesn't solve the problem and M$ should really make a patch that addresses this time wasting and annoying activity but I don't think there's any proper way of fixing it at the moment until then. I have read on another thread that there is this prog in winxp called NET FILE. If you go to the command prompt and type NET FILE it will show you the syntax but I can never work out how you're meant to actually close files with it. martin14041: can you pls tell me where to get that 'End It All' prog you were takling about or any similar program pls.

Thx! :)


I have the same exact problem with .avi files.. right clicked on the file then properties and HD freaking buzzes for 10 min using 100% cpu and slowing everything down, what is with Microsoft. I can't rename, delete avi files as well, posted this problem earlier but didn't get as much replies as now, I thought I was alone but guess not.. Safe mode sometimes worked, it's only useful to go to safe mode command prompt to rename your file if you are not planning to make it a long filename (> 8 characters). I renamed a avi file in safe mode command prompt to 8 letters and when I go back to XP and try to rename it.. it wouldn't work.. Damn Microsoft, I'm waiting for XP SP-1 to come out....


argh, I've had this problem too, but much much much more severe....it was on a secondary hard drive(no OS on it)....I tried everything, disconnecting from network, uncheck archive or read only etc, disabled sharing period, many many many reboots, safe mode, safe mode with command prompt, norton wipe info, using another computer on network to delete the file, taking the hard drive out and putting it on another comp to delete, etc...the final solution was to use partition magic to split the secondary drive into 2 partitions, cut all the files EXCEPT the one that wont delete into new partition, format the partition with the f*cked file, and merge partitions again....MADNESS!!!


two things...
XP+NTFS = :mad:
XP+fat32 = ;)
a bit stoopid dat cos i wan to use NTFS but c'est la vie
as for der other stuff, i find dat renamin an deletin stuff through dos always works with a REAL dos boot disk.. is this just me ffs?
no one wants to do dat all der time though so
create a file in notepad called
routine.bat or somefing(saved in der local root), whack all der commands:

ren originalname newname (for renamin files)
mov origfolder newfolder (for for renamin folders)
del filename

...as u fink of dem den run it in TRUE dos every now an den.:D


Yea i'm using NTFS and suspect that this is part of the problem. Does anyone have this problem when running FAT32?? Anyway, the DOS delete/rename does work but only because you're not clicking once on the file in windows explorer which causes it to lock the file for 10 mins while it does some crap with it! I hope M$ make a fix soon!

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
What a long strange trip it's been. =)

Forum statistics

Latest member