• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Cannot boot with my linux(new Install)

Heeter

Overclocked Like A Mother
#1
Hi Guys,

I finally found a machine for me to dedicate to Linux. It is an old Dell PII266, 32 megs of ram, 3.5 HDD.

I Installed my Linux last night, twice, using both the floppy and then the CD takes over. Once the install is complete, I remove the floppy and CD and reboot, The machine will not boot into Linux. It stays in POST. After a minute or so in POST, it asks me if "F1 to retry boot or F2 to system setup." I tried reinstalling Linux again, Starting with the floppy again and the CD takes over. This time. when Linux asked me where on the HD I want to install it, I saw listed there, the OS and the swap file as installed. I reinstalled anyway. Again I got the same message when the installation was complete. Could it be a setting in my BIOS? I am wondering if it is a BIOS setting. I can get into the BIOS and change first boot devices and such on this dell.

Heeter
 
W

Wolf1.8

Guest
#2
definately sounds like a bios issue. check to see if the hard drive is set as a boot device...should have a boot order 1. floppy 2....etc and 1 of them should be your hd
 

Hipster Doofus

Good grief Charlie Brown
#3
I've only ever used linux once & after installing it I had to use a boot floppy everytime & type startx or something like that to get it going.
 
#4
D E L L = H E L L misspelled.

Dell (and Compaq) used to like to put features in its bios so it only works with Dell Windows and vice versa. Even assuming they haven't done that on this machine Dell uses proprietary components often that may not be supported by Linux.

Also, the bios may be too out of date to support Linux. PII 266 is like a 4-6 year old machine now. Try the Dell web site for a bios update but again you're back into Dells proprietary policies.

I had no trouble at all installing Redhat and Mandarke on an old K6-450 machine. SOYO MB.

Make sure the bios is reset to default settings (all built in functions turned off). Make sure the HD is freshly formatted to FAT or FAT 32 using the linux install disks. There may be some Dell quirk built into track 0 of the HD. If there is, a track 0 repair may purge it but then the machine may be useless with Dell Windows.
 

Heeter

Overclocked Like A Mother
#5
I think that you are right, LeeJend.

Must be a Dell Thing, should of guessed. I will try other stuff Including reset. I am not going to bother with a BIOS update. If it does not work, I am sh#tcanning this computer. This one is the last of my NameBrand-Piece-Of-Junk machines. All my others are self-built.

Heeter
 
#6
Well what Linux distribution were you installing? That Dell shouldn't have any problem at all. Most distributions work as long as the computer has enough RAM and so on. If not, try a smaller distribution. 32MB is probably too little if you're installing a new RedHat or Mandrake for instance. I have a Dell PII 233 in the garage, I think I have ran Linux on it at least once.

Odd **** though.
 

Heeter

Overclocked Like A Mother
#7
I am installing Corel Basic Linux. It is a very, very basic desktop OS. I am going to try to install this HD into my other PIII733 machine and boot from it. That will be the last thing that I am going to try. I will try it later today or tomorrow.

I tried resetting the BIOS (pulling the battery) to no effect. The OS and the swap file are installed correctly into the HD, but it simply will not boot.

Heeter
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,014
Latest member
sanoravies