• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

can a net provider block ICS ??

D

daveqb

Guest
#1
i have just got ADSL put on, & i cant share the net connection like i did with my 56k connection.

the old 56k connection & my new ADSL connection are thru different providers.

the ADSL provider (Telstra Australia) are known for being real tight with their money & try to drain you of every cent they can.

is it in anyway possible they can have blocked me being able to share my connection at home??
i wouldnt have thought so, but can they ??

i can get the share connection to display & able to control it thru the second computer. just cant display web pages, or ping a web page; it always times out!!!

what if i make the second computers IP address the same as the IP of the first computer on the broadband connection??
that way the provider wont know where the request is coming from in case they have some software set up to prevent this (ICS)


any help would be greatly apreciated!!

thanx

PSi have just now tried to conect to ADSL thru the second computer directly & have the other way connect thru this one; in other words swap their roles over.
& still i cant get online with the computer that HAD the SDAL & is now the one wanting to share.
 
#2
No I don't think thay can. That's kind of the point with NAT (Network Address Translation) used in, among others, ICS. You will only see one computer from the outside. It may be possible by running some kind of manual packet scan and analyzing the data by hand. I really doubt they will do that!

Make sure that ICS is enabled on the NIC the DSL is plugged in, or (if you use USB) on the DSL directly.
 
D

daveqb

Guest
#3
enable ICS on the NIC ???

how do i enable it on the NIC??

i dont think its the NIC, as i was able to reverse the situation (ie make the client the host & the host the client) and the same result. only the host can get pages off the net etc.

i found this link to the manual of my ADSL modem. seems a little too over my head to work it out.

just so you know, the client computer, when openning a the browser & trying to conect to a site, is able to find the web site, even advances to "openning......." but just hangs there & i dont get any of the page
?!?!?
 
#4
Originally posted by daveqb
enable ICS on the NIC ???
Um yeah, where else? Go into Network Connections on the ADSL computer. There you will find you NIC(s) and your ADSL connection.

Case1: USB
You will see one NIC LAN connection and a ADSL connection*. ICS should be turned on on the DSL connection.

Case2: Not USB
You have two NICs installed. You see them both in network connections (as LANs). The NIC having the ADSL plugged into it should have the ICS turned on.

* Not entirely sure about this one since I don't have any USB ADSL modem. The point is that the outside has the ICS turned on. I haven't read the manual btw, I'm on a 56k line and I don't want to download 1,7MB at the moment.
 
D

daveqb

Guest
#5
i have actualy enabled sharingon the NIC intead of the ADSL connection, but that didnt make a diiference.

not to say that couldnt be part of the problem.
i just thought i would have to enable share on the connection.
 
#6
Ok have you tried running IPCONFIG in a command prompt on the client?
Check the Default Gateway. Is it set to the IP of the server (ADSL computer)?
 
D

daveqb

Guest
#8
ok ran the ipconfig on the client & heres the result


<hr>


Windows IP Configuration



Host Name . . . . . . . . . . . . : xpbeast

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Mixed

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

DNS Suffix Search List. . . . . . : nsw.bigpond.net.au



Ethernet adapter Local Area Connection:



Connection-specific DNS Suffix . : mshome.net

Description . . . . . . . . . . . : CNet PRO200WL PCI Fast Ethernet Adapter

Physical Address. . . . . . . . . : 00-80-AD-01-E8-D9

Dhcp Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

IP Address. . . . . . . . . . . . : 192.168.0.2

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 192.168.0.1

DHCP Server . . . . . . . . . . . : 192.168.0.1

DNS Servers . . . . . . . . . . . : 192.168.0.1

Lease Obtained. . . . . . . . . . : Thursday, 25 April 2002 3:22:19 PM

Lease Expires . . . . . . . . . . : Thursday, 2 May 2002 3:22:19 PM


<hr>


i hope this makes sense & gives you an idea of what could be the culprit.

i rang my ISP & to get a second connection (costing $11) they recommened using a hub so that each computer can log in & out individually (for the $11 you get a second login user name & password)

so maybe if i just use a hub/switch, & try to share the current connection , it may do the trick! ???


thanx
 
#9
Originally posted by daveqb
so maybe if i just use a hub/switch, & try to share the current connection , it may do the trick! ???
No, (well it could if you did it right but you don't want to, trust me) you can't. The config looks good though. You still haven't said how your LAN is connected. I'm still just assuming you have two NICs in the ADSL computer. A little structural information will make it alot easier to find the problem.
 
D

daveqb

Guest
#10
ok, they are hooked up together via Xover cable.
the ADSL modem goes onto one of the NIC's in the host PC then the second NIC in the host connects it to the client PC.

the client PC can see the ADSL connection, i can connect & disconnect with the client and all, just wont return web pages or anything. i thihnk once a small email slipped thru, but thats about it.

it finds web pages, but times out after minutes on the "openning ..." message

its PPPoE ((dunno if i have mentioned that) and apparently that is a new thing that causes some trouble.

i have yet yo see in any forum ppl sharing a high speed connection using Xover cable & NOt using a hub/switch.

like i think i have said, the LAN works fine, i can share files, printers etc.
 
#11
Ok, it's not the PPPoE if the host can surf. And sharing the way you do should work. Have you tried to access pages using the IP of the server instead of the address name (123.123.123.123 instead of www.domain.com). If you can, it's DNS problems.
 
D

daveqb

Guest
#12
yes tried that at the start of all this
like i said i can get a return on the title of the page, but thats it, it times out after that (left it for 5 minutes!)

heres a new thing i just found out

i can log onto ICQ & send and recieve thru that, thru the Net Gateway (host)

i have given up for now & reluctantly paid for another account, so i have direct access on my computer (client) (bought a switch & some straight thru cable too to facilitate this)

i can cancel the second account later, which i will do once i get this figured out (with everyones help of course)

one would think its an Internet Explorer problem

whats some good IP address's to ping ??
 
R

redsolar

Guest
#13
Solution is probably rather simple

Ok, make sure you do all of the following. TO start with, set all static ip addresses on both PCs for the internal LAN. After you do this, you should have the following:

Server PC:
ADSL NIC: All set to automatic
LAN NIC: IP: 192.168.0.1, subnet 255.255.255.0
That's it nothing else, leave all the rest fields in the LAN NIC EMPTY

Client PC:
LAN NIC: IP: 192.168.0.2, subnet: 255.255.255.0, Gateway: 192.168.0.1, DNS: those two should be exactly the same as both DNS addresses on the ADSL card from the server (do "ipconfig /all" on the server to learn those)

For both PCs to also be able to share files together, make sure you force NETBIOS over TCP/IP in the ADVANCED/WINS settings for both LAN NICs.

That's it, you should be cool now. And remember, don't run network wizard after this, since it will bring you back to the nto always working configuration, which you have now.

Cheers.
 
D

daveqb

Guest
#14
ok done this.

still get the same timming out.

i do wait awhile to give it a chance, 5 minutes. & receive nothing.

i had this set up already, just not the DNS ip's, which i found using ipconfig & put them in, but didnt make a difference.


what else could it be
 
T

TomServo

Guest
#15
How are you connecting the two PC's

Ok, this may ahve been covered in one of the previous posts, but, are you just plugging a plain cat5 cable from one NIC to the other NIC?. Make sure you are using a hub between the two pc's OR use a crossover cable to go directly from one pc to the next.
 
R

redsolar

Guest
#16
Oh, one more thought which is related to TomServo's post:

Can you ping both machine from each other? try running cmd.exe and then typing "ping 192.168.0.1" and "ping 192.168.0.2" from both machines. If it times out, your connection is not working (i.e. something is wrong with the cable).

EDIT Oh, another thing. Sometimes (err very often) this is the case. So give it a try too http://support.microsoft.com/search/preview.aspx?scid=kb;en-us;Q283165

Good luck
 
D

daveqb

Guest
#17
i have used both.

had a Xover going from one to ther other, now got a hub with straight thru cable from both PC's.

like i said the LAN works fine, able to share files & printer. its just the net that doesnt want to be shared by the host PC


this is getting stoopid!!
 
#19
Yes that Microsoft article looks interesting.
Another thing I just thought of, what if this is a "hops" thing. Maybe the computer times out because there are too many hops... Or maybe not since different sites have different hops to them...

Aw check the MTU if you haven't.
 
D

daveqb

Guest
#20
ok, that post with the article must have been at the same time i posted, never saw it , i will give hat a read and try that.

i am willing to give ANYTHING a try !!

gotta go to work now .......
 

Members online

Latest posts

Latest profile posts

Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,016
Latest member
doertilog