• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Bootable XP cd with SP1 integrated

#1
I was following the directions on http://www.tacktech.com about making the bootable Win XP cd with SP1 integrated and I have hit a snag. I created the directories structure described in the article and extracted the service pack to C:\XP\XP-SP1....then I copied the entire XP cd to CD-ROOT. Then I open a command prompt and navigate to C:\XP\XP-SP1\Update and run update.exe -s:\C:\XP\CD-ROOT and get the following error message...."Failed to copy some or all of the files necessary for integrated install. Please check that : a) No network or copy errors occurred during the integration process. b) The format of the destination directory is incorrect.

The thing is....the C:\XP\CD-ROOT\ does contain the i386 directory. Any ideas?
 
P

purush

Guest
#4
There is a problem with the command given in that site. However, there is a workaround for it. Here it goes, Do everything as it says in the begining, ie, create three folders etc,. After you have done that and copied the XP Cd contents( make sure that there are 9 files in it) in the CD-ROOT and boot bin file in the XP-BOOT folder respectively, IGNORE the first command to copy the XPSP1 file, manually unpack the contents of SP1 to the XP-SP1 folder you created inside XP folder and then, copy and paste the second command in the run and run it from there. That's it, you will see the window 'updating your window share' come up. I have done this successfully including burning the bootable CD. Everything works.Good luck
Peter
 
H

Hud

Guest
#9
I have tried not renaming and running the command and I tried winrar and I still have the same problem. I have tried extracting with PowerDesk 4.0 but get a error. Any other suggestions.
 
H

Hud

Guest
#11
I don't think it's a corrupt download because I installed The SP1 update on my computer without a problem. I'm only having a problem trying to make the updated XP disk.
 

Hipster Doofus

Good grief Charlie Brown
#12
Having a bit of trouble following what you said at the start so that's where I'll go.

If you have made the folders & put everything in place then the run command is this>
C:\XP\XP-SP1.EXE -U -X:C:\XP\XP-SP1 ( that's fron the website & some are having ttrouble here)

I left the name of sp1 unchanged so mine looked like this>
C:\XP\xpsp1_en_86 -U-X:C:\XP\xpsp1_en_86
I put that into the run box not the command prompt & away it went.
 
T

The_Schwarz

Guest
#13
if you hace any spaces in your directory make sure you enclose them with spaces

i.e c:\wxp sp1\ becomes "c:\wxp sp1"
 
H

Hud

Guest
#14
I can get that far. The problem I'm having is trying to run the command "C:\XP\XP-SP1\UPDATE\UPDATE.EXE -S:C:\XP\CD-ROOT " that's when I get the failed to copy some or all files message.
 
#15
you unpack the service pack with the -X flag....so if the service pack is named xp-sp1.exe...go to the command prompt and type xp-sp1.exe -X and it will prompt for you a directory to unpack the service pack to
 
P

purush

Guest
#16
XP\Ref: How to manually unpack. Make a copy of your SP1, the one that came directly from MS. Unpack means to move the file SP1 after renaming it to XP-SP1.EXE to the XP-SP1 folder that you create. Once placed inside this folder right click the SP1 EXE file and check 'extract here' this will extract SP1 into the folder. Finally, copy and paste the last command. C:\XP\XP-SP1.EXE -U -X:C:\XP\XP-SP1......there is space after EXE and U. Hope it helps
 

Capricorn

OSNN Senior Addict
#18
I'm also have trouble with this. I have managed to do all the things suggested, and have made a disc. However, it will not boot up. Secondly when I open the disc, it contains a single folder, which does have the XP folders in it, by selecting install it opens with the usual install XP options. Where am I going wrong.
 
H

Hud

Guest
#19
Thanks for all the replys. I have tried all the suggestions to unpack the SP1 files. I can unpack the SP1 files to the XP-SP1 directory but when I try to run " C:\XP\XP-SP1\UPDATE\UPDATE.EXE -S:C:\XP\CD-ROOT " I get the same error message as in the original message in this thread. any suggestions how to get past this problem?
 

Capricorn

OSNN Senior Addict
#20
Did you make sure that your Root Folder contains all the files and not just the One Folder. My problem appears to be the Boot Files. When I un zip them into the Boot Folder all I get is this one file:- Boot AVG Update File 2kb. Surely this cannot be right?
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,014
Latest member
sanoravies