Battlefield 1942 wont run

Doom

OSNN Senior Addict
#1
I've just installed battlefield 1942 and I cant get the game to run. When I try to run the game the splash screen comes up then goes the a blank screen comes up and goes then nothing. I've put in the latest patch to see if it makes any difference but it did'nt. Can anyone help me? Please.
 

MeFo

el mafioso
#2
hi
i had the same problems, and realized that was a refresh problem, if you installed refreshlock or refreshforce, be sure to disable any 60hz tweaking, after that, run bf1942, and it will run at 60hz, but it will run
its a pain but, it has to be done
 
B

bandworthy

Guest
#3
Or after installing 1.2 patch, find "VideoDefault.con" which should be under mods/ bf1942/settings/ in your ea games folder (if your version 1.2, since the directory structure was changed in that version) and change the line using notepad

renderer.allowAllRefreshRates 0

to

renderer.allowAllRefreshRates 1
 

GoNz0

NTFS Stoner
#4
go into program files/ea games/ BF 1942/mods/bf 1942/settings and open the file videodefault with notepad, edit or put in this line to allow the value to read 1

renderer.allowAllRefreshRates 1


and try again.
 

Gus K

NTFS abuser
#5
If that's the case that you are using a refresh rate fix utility you must make a small change in BF's VideoDefault.con file. This will then show/allow all the refresh rates that are available with your monitor when you go to video options in the game. You will no longer need any utility to have a proper refresh rate. I am confused as to why EA chose to lock the game into 60hz though.

With SP1 installed you can now change refresh rates for all D3D games. If you have any OpenGL games, though, you will still need a refresh rate utility.

A good BF tweaking page, which explains more fully can be found here:
http://www.tweaktown.com/document.php?dType=review&dId=420
 
B

bandworthy

Guest
#6
"I am confused as to why EA chose to lock the game into 60hz though. "

apparently it was over looked considering some of the bugs the game was shipped a bit early although it is in my opinon the best game at the moment still come on 1.3 patch!!.
 

Doom

OSNN Senior Addict
#7
thank's folks. I took out the refresh tool and uninstalled and reinstalled the drivers. Hope they fix it in the next patch
 
B

bandworthy

Guest
#8
erm did you change that line that we mentioned a few times here? thats your problem it would work and you can run it at any refresh rate then with any refresh rate tool, infact you can select the refresh rate ingame once you change that line.
 

Doom

OSNN Senior Addict
#9
Originally posted by bandworthy
Or after installing 1.2 patch, find "VideoDefault.con" which should be under mods/ bf1942/settings/ in your ea games folder (if your version 1.2, since the directory structure was changed in that version) and change the line using notepad

renderer.allowAllRefreshRates 0

to

renderer.allowAllRefreshRates 1

I found the icon ok but I don't know how to change it using notepad. Do I right click on it or something?and is there an option in there. I've read about people doing this sort of thing before but I've never had do do it myself so I don't know how to.
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,971
Messages
673,299
Members
89,016
Latest member
Poseeut