ATI Catalyst 3.10

xsivforce

Prodigal Son
#1
ATI CATALYST drivers provide fully qualified display support for Windows XP Media Center Edition 2004 systems with Radeon display cards, but requires a special version of ATI's Video Capture (WDM) drivers for Windows XP Media Center Edition 2004 systems with All-in-Wonder boards, which will be provided by your computer manufacturer.
XP Driver Downloads
 

Sazar

F@H - Is it in you?
Staff member
Political User
#5
Electronic Punk said:
4.1 should be out soon shouldn't it ?
there may be upto 3.11 or 3.12 public release but yes... I think 4.xx should be out soon
 

Alex_is_Axel

.:: FTPAlex ::.
#7
i cant wait for the 4.XX's to be released, should be interestingf to see. I wonder if there is going to be much of a difference between the 3.XX's and and 4.XX's.. heres hoping there would be a noticable increase in performance

Does anyone know anything about the 4.XX release?

Alex :cool:

Nice to see the forums comming back to place
 

Xie

- geek -
#8
Although I'm not sure if I have noticed any improvements performance wise I don't see any de-performance as I have seen sometimes w/ newer drivers :) I have been to lazy to take the few minutes to benchmark them as well ...
 

luish

OSNN Senior Addict
#9
I don't like the current drivers.
As you all know the new Nvidia drivers, when they changed to v52.0 right ?
I heard from friends that there was a huge perfomance improvement, I also read this on the net, I just hope new version will make a huge imporvement too !
 

luish

OSNN Senior Addict
#17
I must say that the Omega ones made me some troubles, I think that they almost fried up my Radeon... Pc started to beep, monitor went off and I went back to 3.10 but I feel this are not good to me...
 
#18
luish said:
I must say that the Omega ones made me some troubles, I think that they almost fried up my Radeon... Pc started to beep, monitor went off and I went back to 3.10 but I feel this are not good to me...

i couldnt even get my to load up properly.. it kept saying i didnt have drivers.. i tried installed after uninstalling my 'stock' 3.10 drivers, then i tried just updating them with the 'stock' 3.10s installed without uninstalling... i dont get it, they just didnt want to show up.. go fig....
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,969
Messages
673,295
Members
89,016
Latest member
mopiyaloog