ASPI problems

Cupid_Stunt

OSNN Addict
Joined
4 Jan 2002
Messages
75
Help damn thing wont install, followed all the instructions on how to do it.

Also downloaded the same program for the install from 6 different places, and get same results.

When i run it it just says cannot find specified path in the black window.

Run all three processes to do the install and rebooted then run aspi check and there's nothing there atall.

So can somebody suggest anything better way of doing it.

regards.....Cupid_Stunt
 

Lonman

Bleh!
Joined
2 Dec 2001
Messages
2,642
You need to run 'aspi.bat' first. This will put the qualifying files in the right directories, then you run 'aspi32.exe' to install the aspi layer.
 

Cupid_Stunt

OSNN Addict
Joined
4 Jan 2002
Messages
75
I did run the bat first then the others, and still not installed.

When i ran the bat, it said cannot find specified path hit any key to continue,. so hit and says same thing.

It will not install and im no pro im puter thick so if anybody knows of another way to do it, please give me step by step instructions.

Many thanks
regards Cupid_Stunt
 

Lonman

Bleh!
Joined
2 Dec 2001
Messages
2,642
Ah, that's your problem. The aspi32.exe will only install if you have a qualifying product.

Do this, edit (open) the aspi.bat file and manually copy the target files to those directories, then run the aspi32.exe file.

here, put these files (in the files folder) in these destinations:

echo Copying aspi32.sys...
copy files\aspi32.sys %sYSTEMROOT%\SYSTEM32\DRIVERS

echo Copying winaspi.dll...
copy files\winaspi.dll %sYSTEMROOT%\SYSTEM

echo Copying wnaspi32.dll...
copy files\wnaspi32.dll %sYSTEMROOT%\SYSTEM32

echo Copying wowpost.exe...
copy files\aspi32.sys %sYSTEMROOT%\SYSTEM
 

XeoNoX

OSNN Senior Addict
Joined
3 Dec 2001
Messages
271
download this http://63.116.218.206/files/nt_aspi.zip
 

Cupid_Stunt

OSNN Addict
Joined
4 Jan 2002
Messages
75
Many thanks Lonman will try to do that and let you know how i go on as soon as.

Thanks
best regards.....Cupid_Stunt
 

Cupid_Stunt

OSNN Addict
Joined
4 Jan 2002
Messages
75
Sorry i opened bat file and tried edit ican see each line of text how you put it but how do i copy it and is it a cut and paste job,

told you i was thick,

How the hell do i copy it , its just a line of text,
May be easy to you but not to me.

regards.....Cupid_Stunt
 

Cupid_Stunt

OSNN Addict
Joined
4 Jan 2002
Messages
75
OK get them in the right folders and then run aspi exe,
all ok then it rebooted and stopped on boot saying

Disc read error occured and press ctrl and so on to reboot so did that and it just goes back to saying that,

how can i get it to boot fully...
 

Lonman

Bleh!
Joined
2 Dec 2001
Messages
2,642
I don't think the two are related. Locking up and your aspi layer. The aspi layer is actually pretty passive until it's used.

According to your Private Message you said the aspi.exe said to reboot and you say, "so did that it booted up ok then 5 minutes later doing nothing on it and it locked up."

Try to boot into safe mode and run 'chkdsk c: /f' from the run box in your start menu. To get to safe mode, reboot, and just before XP starts to load start to hit the F8 key (just keep tapping it). This will give you the boot options to go into safe mode. Once there run the chkdsk command. It should give you a message that it needs to reboot to perform the check on your drive. Let it reboot again and check your drive for errors. Hopefully that will fix you up, but there's no gaurantee.
 

Cupid_Stunt

OSNN Addict
Joined
4 Jan 2002
Messages
75
Many thanks for all your help,

Found out the Hdd is knackered.

wont boot, wont format, wont fdisk.
even in 3 other machines, so that will be going back to the store for a replacement.

But one good thing is now i know how to put in aspi manually.

Thanks best regards.....Cupid_Stunt
 

Lonman

Bleh!
Joined
2 Dec 2001
Messages
2,642
Oh man that really sucks. I hope you didn't lose something really important in the crash. Was there any indications it was going bad, or did it just die?
 

Members online

No members online now.

Latest profile posts

Electronic Punk wrote on Sazar's profile.
Rest in peace my friend, been trying to find you and finally did in the worst way imaginable.
Terrahertz wrote on Electronic Punk's profile.
Yo fellas!
Electronic Punk wrote on Sazar's profile.
Where are you buddy?
Perris Calderon wrote on Electronic Punk's profile.
Hey EP! All good with me, applying for Microsoft MVP right now, should have done this a while ago.

Notifications don't work, I only found your response by coming back to hunt up some threads, if you want, give me your email address so we can keep in touch easier!
Perris Calderon wrote on Electronic Punk's profile.
EP, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there!

Forum statistics

Threads
61,997
Messages
673,402
Members
5,586
Latest member
PseudoKiller