• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Apache

DrMetallica

OSNN Senior Addict
#1
God guess what have I been doing awake for 20 hours? :confused:

Installing Apache and trying to get the damn password protector to work right. :mad:

I want to have my own webserver ( http://www.drmetallica.cjb.net ) so when I go to school I can have all my scheisse( homework in german :D ) on the web so i dont have to bring 100 floppy disks to school. :cool:

Also I want to have a music folder for when I want to have some nice mp3's on when i iz at me Julie's gettin some mad muff poonani. ;)

I don't want the music folder password protected but I do want the school folder protected ( I don't want any of me m8's going on my personal web server and download my scheisse ( or homework ) and saying it's their own!!! :mad: )

me and me m8 ( http://www.drakesland.cjb.net ) haz been trying to get this right on my server but no go...its not working. :(

would it be easier just to password-protect the entire site? :confused:

Right now I am stumped on ideas
 
#3
I think you need to put a .htaccess file in the school directory. Or you could set per-directory options in the Apache config file.
 

DrMetallica

OSNN Senior Addict
#4
After 72 hrs of little sleep and much fustrasion, I finally figured got it. I had the .htpasswd and .htaccess in the right places, and the right syntaxes for those, but i didn't have the httpd.conf configured correctly. I just changed all the "AllowOverride None" to "AllowOverride AuthConfig" wich didn't do scheisse. I needed to put a whole new directory syntax in...here is the text that got me rolling....

Password Protecting Directories Using Apache - Eric Cables:
-----------------------------------------------------------

First go to the directory in which the files you wish to password
protect are located. Do the following:

Make a file named .htaccess containing the following:

AuthName "Brief Description"
AuthType Basic
AuthUserFile /dir/where/you/want/.htpasswd
require valid-user

Once that is completed, go to the directory where you have
.htaccess looking for the .htpasswd file. You need to
create a userlist for allowed-users. Do this by typing the
following:

cd /dir/where/you/want/.htpasswd
htpasswd -c .htpasswd <user>

You will be prompted for a password, and confirmation.

Finally you need to make a modification to the httpd.conf file.
Add the following lines to httpd.conf and HUP the server. This
should implement your password protection.

<Directory "/home/httpd/html/password/protected/directory">
Options Indexes FollowSymLinks
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>


Troubleshooting:
----------------

Check your error_log file if you are receiving any server errors,
it is often very helpful.

error_log example(s):

[Thu Feb 3 13:48:20 2000] [error] [client 216.32.160.110] File does not exist:
/home/httpd/html/mrtg/mrtg-m.gif
[Thu Feb 3 13:48:20 2000] [error] [client 216.32.160.110] File does not exist:
/home/httpd/html/mrtg/mrtg-l.gif
[Thu Feb 3 13:48:20 2000] [error] [client 216.32.160.110] File does not exist:
/home/httpd/html/mrtg/mrtg-r.gif

The above is due to a file not found (duh!)

--

[Thu Feb 3 13:39:32 2000] [alert] [client 216.32.160.110] /home/httpd/html/mrtg/.h
taccess: AuthUserFile takes 1-2 arguments, text file containing user IDs and passwo
rds
[Thu Feb 3 13:39:34 2000] [alert] [client 216.32.160.110] /home/httpd/html/mrtg/.h
taccess: AuthUserFile takes 1-2 arguments, text file containing user IDs and passwo
rds

The above is due to a mis-configured .htaccess file. No directory was
specified after the line: AuthUserFile



blue
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,014
Latest member
chawalsub