Antec PLUSVIEW1000AMG - Front USB Ports Problem

sammy5gs

Ignorance Defined
Joined
Feb 9, 2004
Messages
44
#1
Hey All...

I own this case
,

and the problem I am having is that were that mini-compartment is in front (where is says Antec) houses front panel USB/firewire ports. However, every now and again, when I go to plug in a USB device (camera, gamepad, etc), the port gets pushed in from it's housing (plastic housing clip), and then I have to go in, open the case up, and place it back into it's normal position. Once I do that, it looks secure, until the next time where some overly exerts pressure (anything more than a 8 year old would seem to do the trick), it gets pushed in again.

Any thoughts on how I can fix this problem for good? I am guessing superglue, plastic model cement, etc, but wanted to bounce it off of you guys first.

What are your thoughts?
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
62,000
Messages
673,427
Members
89,025
Latest member
Haniew