ADSL Modem not connecting to Router

Nick

OSNN Lurker
#1
I have on occasion tried to set up ADSL connections with varying degrees of success. My current challenge is to set up a Nokia IP40 with a D-Link DSL-300T.

I can quite happily get to both config pages if they are plugged directly into my computer, and plugging the modem into my computer gives me internet access. The problem comes when I try to plug the IP40 into the ADSL modem to route the connection.

I know its not a cable problem as the Nokia can get the IP address of the gateway. The problem is that the IP40 seems to block the DHCP broadcast from the modem, so it doesn't get a WAN IP assigned. It also thinks the D-Link is spoofing it's IP address, although I've no idea why. If I change the IP of the D-Link from 192.168.1.1 (default) to 192.168.0.1 the Nokia no longer says the Ip is spoofed. The Nokia is set up to receive its WAN IP via DHCP and when my computer is plugged into the modem it gets an IP assigned with no problems.

Thats a bit of info to get you started, has anyone got any ideas?
 

Reg

eXperienced!
#2
It sounds to me as though everything is working properly, just need to make a few adjustments.

Modem ---> Sends WAN IP Address
Router ---> Receives WAN IP Address. Transmits DHCP Private Address (192.168.1.1)
Computer ---> Receives DHCP Private Address (192.168.1.2 or greater).

When you use a router, your router will not give you a public IP address because the router uses NAT (Network Address Translation) to convert your private address into a public address. This is why you can share a single internet connection with hundreds of PCs without having to pay for multiple public IPs. NAT is also used as a firewall mechanism since IEEE and TCP/IP standards do not allow private addresses to travel on the internet. Thus, it provides a layer of protection since outsiders can not access your computers directly, only your router (which should be secure most of the time).

I'm not sure about why you are getting the spoofing incident. What I would try doing is power cycling your modem and your router after you have connected them. Further, make sure that you are plugging the ethernet cable coming from your modem into the routers WAN port.
 

Nick

OSNN Lurker
#4
Zedric: The DLink does have and IP as it has a web based configuration panel that can be accessed on it.

Reg: It sounds to me like everything is set up properly as well, thats why I can't figure out why its not working :( I powercycled the router and modem again with the same results.

Looking at the Nokia config page, the network status gets as far as "Establishing Connection" and no further. It doesn't hang as it keeps sending packets to the modem, but never receives any back.

I've attached the diagnostics page (product key and serial removed) from the router so you can see exactly how far I've got.

Any and all help is greatly apreciated. Thanks.
 

Attachments

Nick

OSNN Lurker
#6
When the Modem is plugged directly into my computer I can access the modem config page, but when it is plugged into the router I can't see the modem config page.

I've tried the ADSL modem on 192.168.1.1 and 192.168.0.1, the router on 192.168.1.1 and 192.168.1.2.

With the Modem IP set to 192.168.1.1 I get the 'Spoofed IP' message appear in the router event log. With the modem on 192.168.0.1 it still shows a blocked connection but doesn't list it as a spoofed IP.
 

Nick

OSNN Lurker
#8
yeah, wan, lan and dmz. Nothing is plugged into the DMZ at the moment and the LAN and WAN cables are plugged in the right way round :)

I've set up similar setups in the past, but not with an IP40. The only reason I'm using the IP40 at the moment is to comply with group standards, who have said they aren't going to offer any help till after september 'coz they are to busy :confused:
 
#9
Just to be curious try hooking your computer to the dmz port. The dmz would put your computer on the outside of the router but just for kicks give it a try.
 
#11
Is that the only router you have or have you tried it with another one? Have you tried updating the firmware? Just throwing out ideas?!?!
 

Nick

OSNN Lurker
#12
I haven't got a spare router to test it with unfortunately and the firmware is the latest available.

Thanks for the ideas, keep them coming.
 
#13
I've been researching a bit and have read that you must hook the modem up to the router before running the configuration. Did you do that? Does the modem have a reset on it?
 

Nick

OSNN Lurker
#16
Ah, this is new! I'll go try and report back. Cheers for the help Kreepy. I've spent quite a bit of time googling it without any success.
 
#17
Configure the router with the username and password then hook the router up and run the cofig on the modem.
Don't know if it will help any but i have my router set to 192.168.1.1 and my modem is 192.168.100.1. I have a cable modem though, but you never know.
 

Nick

OSNN Lurker
#18
Well here's what happened. Reset modem to factory defaults, hooked it up to the router. The router established a connection to the modem!

The next problem I've got is with the router. If I was setting the connection up on the modem I would use PPOA, but the router doesn't have a PPOA option. It does however have PPOE and PPTP. Which one should I be going for?

Cheers
Nick
 
#20
Similar issue with D-Link DSL300T

I have a SMC 2804WBRP-G wireless router with print server connected to the web via the D-Link DSL modem. The problem is that I can set-up my network and all runs. When I power down the router or leave it idle for a while, I cannot access the net. I can access both the router and the modem from all pc's and teh only way to restore the connection is to release and renew the DSL connection within the status panel of the router set-up programme.
The router does not support PPPOA. The modem IP address is 192.168.1.1 and the router 192.168.2.1.

I have called SMC and they want me to disable all firewall settings to allow connection of the modem into a LAN port rather than the WAN.

Anyone any ideas?

(SMC claim WPA security for this router but it isnt, a subject for another forum).
 

Members online

No members online now.

Latest posts

Latest profile posts

Perris Calderon wrote on Electronic Punk's profile.
Ep, glad to see you come back and tidy up...did want to ask a one day favor, I want to enhance my resume , was hoping you could make me administrator for a day, if so, take me right off since I won't be here to do anything, and don't know the slightest about the board, but it would be nice putting "served administrator osnn", if can do, THANKS

Been running around Quora lately, luv it there https://tinyurl.com/ycpxl
Electronic Punk wrote on Perris Calderon's profile.
All good still mate?
Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,971
Messages
673,300
Members
89,016
Latest member
Poseeut