• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Active Desktop Help...

Promiscuity

OSNN One Post Wonder
#1
I'm trying to use HTML Image mapping to assign hyperlinks to run programs. I tried this:

<area shape ="rect" coords ="985,531,1093,542"
onClick="exec('firefox.vbs'); return false;"href="firefox">

and it seemed to work well enough. However, whenever I try doing this with any other application, it just doesn't do anything. It doesn't say anything, it doesn't load, it just sits idly. So I try right clicking it and it says it can't find it. Interesting enough is that if I right click->open firefox, it says the same thing, but it works if I left click it... can anyone tell me what's wrong?
 

madmatt

Bow Down to the King
Political User
#2
Code:
<map name="deskbar">
  <area shape="rect" coords="985,531,1093,542" onClick="exec('firefox.vbs'); return false;" href="javascript:void(0)">
</map>
 

Promiscuity

OSNN One Post Wonder
#3
Thanks, but does it only work with opening web browsers? IE and FF both work, but none of my games, or any other applications work with it...
 

madmatt

Bow Down to the King
Political User
#4
I don't know about image maps, never tried the code in an image map.

Try using regular links. The code works for any file, folder, or executable.
 

Promiscuity

OSNN One Post Wonder
#5
Ok, I used this code to try launching Guild Wars:
<a onClick="exec('gw.vbs'); return false;" href="java script:void(0)">Launch Guild Wars</a>

This is what the VBS file looks like if that matters:
Dim oShell
Set oShell = WScript.CreateObject ("WScript.shell")
oShell.run "gw"
Set oShell = Nothing

Same thing happened, except it was a regular link at the top of the screen.
 

Promiscuity

OSNN One Post Wonder
#6
Well, I tried putting the direct directory in the quotes like in the tutorial, but not it says it can't even find the vbs file under the WINDOWS file, when I'm looking straight at it.
 

madmatt

Bow Down to the King
Political User
#11
SP2 I assume?

Make sure there is no space between "java" and "script" in the HREF statement. Because of the way the site displays the code it puts a space in and that's the problem most people have.

Code:
<a onClick="exec('gw.vbs'); return false;" href="javascript:void(0)">Launch Guild Wars</a>
I would also recommend moving all your VBS and shortcut files to a different location (created by you). I have mine in D:\Desktop\Shortcuts. All you have to do is add that path to the PATH variable (as explained in the guide).

If you are still having issues make sure any security suite (such as Norton, Trend Micro, etc.) and malware protection software is allowing access to the VBS files. Older versions of Norton IS/AV, for instance, block VBS files from running.

Let me know.
 

Promiscuity

OSNN One Post Wonder
#12
Ok, I created a new file on my desktop called Active Desktop. A shortcut to C:\Program Files\Guild Wars\Gw.exe, and a VBS file with this inside:
Dim oShell
Set oShell = WScript.CreateObject ("WScript.shell")
oShell.run "C:\Documents and Settings\Jerry\Desktop\Active Desktop\Gw.exe"
Set oShell = Nothing

was made also. So I add
<a onClick="exec('gw.vbs'); return false;" href="javascript:void(0)">Launch Guild Wars</a>


w/o the spaces in the href. So I click on the link, and it opens up Internet Explorer, with javascript:void(0) in the address bar and the caption at the top.
 

Promiscuity

OSNN One Post Wonder
#14
It does go to a shortcut, the shortcut made in the same folder as the script right? Anyways, I'm pretty sure it's not the VBS, as I can run it by clicking it, and it works... Same thing happened with Internet Explorer when I try clicking the link in the active desktop though..
 

madmatt

Bow Down to the King
Political User
#15
Using the tweak in the guide add the My Computer Security Zone to Internet Explorer properties. Reboot. Then tweak the settings to allow VBS/ActiveX for the My Computer Security Zone.
 

Promiscuity

OSNN One Post Wonder
#16
- Highlight the "My Computer" zone icon
- Click "Custom Level"
- Under "ActiveX controls and plug-ins", change "Download signed ActiveX controls" to "Enable"
- Change "Download unsigned ActiveX controls" to "Enable"
- Change "Initialize and script ActiveX controls not marked as safe" to "Enable"
- Change "Run ActiveX controls and plug-ins" to "Enable"
- Chnage "Script ActiveX controls marked safe for scripting" to "Enable"
- Click "OK"
- Click "Apply"
- Click "OK"


That?
Did that, same thing happened, Internet Explorer says it won't allow it to run, so I allow it, then the javascrip:void thing comes up and nothing happens.
 

Members online

No members online now.

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,015
Latest member
sanoravies