• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

802.11g Connectivity issues

#1
My girlfriend has just purchased an Advent 8115 laptop, its a good quality machine for its price and runs Vista Premium.

It has according to Device Manager a RT73 USB Wireless Card, the wireless card is in fact internal and not USB dongle but we cant seem to connect to my Belkin G+ Mimo router, Its showing a full 5 bar signal but still wont connect. I also have and Macbook and another older Advent laptop running XPSP2 Media Centre Edition which all have no problem's connecting.

I hope that this is simply a software issue with compatibility with Vista. Has anyone got any idea's how to try to solve this annoying problem?

Cheers
 

Brad

Moderator
Political User
#2
It may seem obvious but do you have MAC based authentication or any encryption turned on on the router?
 
#4
No MAC encryption, but i do run WPA Pre-SK and have checked the password over and over again.
FWIW, I've seen this issue several times with WPA and WPA2. More often than not, a driver update fixed the problem. For some reason it's happening quite a bit on new equipment. At work, we just purchased 2 new laptops that had the same problem...so who knows. Anywho...check the driver.

One other thing I've encountered is that some wireless devices absolutely refuse to connect using Windows...but rather require you to connect with their own proprietary utility...so check into that too...

Hope this helps!
 
#7
Sorry, I had previously been sidetracked.

No luck im afraid, I have updated drivers and added 3rd Party Application for the RT73 Card. I have checked that the router is running the latest firmware, which it is. I have tried changing the Channel from 1 through 13 to try to advoid some interferance.

The only thing I have noticed is disabling WPA and WEP so that there is no Encryption what so ever the connection appears to be that little bit more stable. However I have resumed to using WPA2 as it isnt advisable in my area to have an open network.
 

lancer

There is no answer!
Political User
#8
sean, disable all security on your router and try and connect then, if it connects you've found your issue if not, well one thing down.
 
#9
When I disable the Security (as mentioned above) the connection appears more stable, however it does still drop the connection randomly from time to time. I have sent an e-mail to Belkin and I am considering upgrading the firmware to their "pre-release" version.

[edit] - I played around with my network configuration and eventually reverted back to the Dynamode router. Everything works fine now, no connectivity issues at all. Which is odd, but perhaps a windows update fixed issues?
 
Last edited:

Members online

Latest posts

Latest profile posts

Hello, is there anybody in there? Just nod if you can hear me ...
Xie
What a long strange trip it's been. =)

Forum statistics

Threads
61,961
Messages
673,239
Members
89,014
Latest member
sanoravies