XP opengl problem?

Discussion in 'Windows Desktop Systems' started by Nuts, Dec 14, 2001.

  1. Nuts

    Nuts Guest

    or is it just me? Every time I try to run rtcw or the new mohaa demo I get this error
    --- Common Initialization ---
    Medal of Honor Allied Assault 1.00 win-x86 Dec 12 2001
    ----- FS_Startup -----
    Current search path:
    E:\Program Files\MOHAANetDemo\main\Pak5.pk3 (6 files)
    E:\Program Files\MOHAANetDemo\main\Pak4.pk3 (284 files)
    E:\Program Files\MOHAANetDemo\main\Pak3.pk3 (397 files)
    E:\Program Files\MOHAANetDemo\main\Pak2.pk3 (490 files)
    E:\Program Files\MOHAANetDemo\main\Pak1.pk3 (199 files)
    E:\Program Files\MOHAANetDemo\main\Pak0.pk3 (1546 files)
    E:\Program Files\MOHAANetDemo/main

    ----------------------
    2922 files in pk3 files
    execing default.cfg
    execing menu.cfg
    execing newconfig.cfg
    Config: unnamedsoldier.cfg
    couldn't exec configs/unnamedsoldier.cfg
    couldn't exec localized.cfg
    execing autoexec.cfg
    Unknown command "fov"
    couldn't exec custom.cfg
    ...detecting CPU, found AMD w/ 3DNow!

    ------- Input Initialization -------
    Initializing DirectInput...
    Couldn't set DI coop level
    Falling back to Win32 mouse support...
    ------- Input Initialization Complete ------- 8
    You are now setup for easy mode.
    ----- Client Initialization -----
    Called FadeSound with: 0.000000
    ----- Initializing Renderer ----
    ----- R_Init -----
    Initializing OpenGL subsystem
    ...initializing QGL
    ...calling LoadLibrary( 'C:\WINDOWS\System32\opengl32.dll' ): succeeded
    ...setting mode 4: 800 600 FS
    ...using colorsbits of 32
    ...calling CDS: ok
    ...registered window class
    ...created window@0,0 (800x600)
    Initializing OpenGL driver
    ...getting DC: succeeded
    ...GLW_ChoosePFD( 32, 24, 8 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...GLW_ChoosePFD( 32, 24, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...failed to find an appropriate PIXELFORMAT
    ...restoring display settings
    ...WARNING: could not set the given mode (4)
    ...setting mode 4: 800 600 FS
    ...using colorsbits of 16
    ...calling CDS: ok
    ...created window@0,0 (800x600)
    Initializing OpenGL driver
    ...getting DC: succeeded
    ...GLW_ChoosePFD( 16, 16, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...failed to find an appropriate PIXELFORMAT
    ...restoring display settings
    ...WARNING: could not set the given mode (3)
    ...shutting down QGL
    ...unloading OpenGL DLL
    ...assuming '3dfxvgl' is a standalone driver
    ...initializing QGL
    ...WARNING: missing Glide installation, assuming no 3Dfx available
    ...shutting down QGL
    GLW_StartOpenGL() - could not load OpenGL subsystem

    whats this nonsense? Oh sorry, I'm running a geforce3 w/ 21.85 drivers
     
  2. wrangler

    wrangler Guest

    drivers that shipped with XP have no OpgenGL support

    install a different set of drivers to get OpenGL support, try the 22.50 Gainward drivers, they work wonderfully......:D
     
  3. bigshadow

    bigshadow Guest

    testing out

    this is a test!!!!!!!!!!!!!!!
     
  4. Bytes Back

    Bytes Back Ex Police Chief

    Messages:
    1,383
    Location:
    Kernow
    Ye Gods !!! I've been playing MOH for over 3 Years !!! :eek: :eek:
     
  5. SPeedY_B

    SPeedY_B I may actually be insane.

    Messages:
    15,800
    Location:
    Midlands, England
    Please don't keep bumping legacy threads.