XP has just slowed to a crawl

Discussion in 'Windows Desktop Systems' started by Guru-Choc, May 5, 2002.

  1. Guru-Choc

    Guru-Choc Guest

    Anyone had this before, yesterday while showing my mate something it started to play up, explorer opens slowly and all tasks seem to take forever to load. Interestingly I have traced it only to my C: drive(and partitions on it), opening up through the start menu and going to my computer, if I select C: it takes forever to open up and disply the directory structure, if I pick D: which is my second drive it opens and displys in a flash. I had noticed this during the week when transferring files between physical drives, but thought nothing of it.

    I have removed my Virus checker to see if the real-time scan had been enabled by accident and was still on even though I told it to turn off, but this made no difference.

    I am at a loss to explain this slowness, any ideas appreciated.
     
  2. dadx2mj

    dadx2mj Guest

    Check the drive controler and make sure it is still running in DMA and has not got switched to PIO mode or something. I would also check the task manager and see if there is something running in the background.
     
  3. allan

    allan Guest

    Did you run a full virus scan before removing the AV (and I'd strongly recommend reactivating the AV). You might also want to run ad-aware.

    But both scans come up clean, I think the above suggestion to check all running services is smart. Open msconfig and do a selective startup, disabling everything. Then add one item back at a time until the problem recurs and you'll have identified the culprit.
     
  4. Guru-Choc

    Guru-Choc Guest

    Thanks for the tips, turns out the drive had set itself to PIO mode somehow, changed that to DMA and all is fine agin, although knowing what did this would make me feel better. Thanks for the tips again.