WTF, XP wont let me change virtual memory! HELP!

Discussion in 'Windows Desktop Systems' started by Spanko, Jun 24, 2002.

  1. Spanko

    Spanko Guest

    Ok, I right click my computer set navigate to virtual memory tab and set it to 256 minimum and 256 maximum. I have 512 DDR and i dont need more. And even though it says its set at that its not. In the system information tab it says it sets way higher. This is VERY frustrating can someone please help me? Ive enclosed 2 screenshots.

    http://www.liquid2k.com/spanko/wtf.jpg

    http://www.liquid2k.com/spanko/wtf2.jpg
     
  2. stuy_b

    stuy_b Guest

    Are you sure you are doing it right, because after setting the size and clicking set, then you click OK to close the performace window.. windows should immediately ask you to reboot. Make sure you click SET and then the OK button at bottom of window.
     
  3. Spanko

    Spanko Guest

    Yes, I did all that.
     
  4. Perris Calderon

    Perris Calderon Moderator Staff Member Political User

    Messages:
    12,333
    Location:
    new york
    OK, I can't figure this out, accept it's possible XP is finding a different area to page then your page file...I don't think that's it though, but I am driven to bring up a different issue.

    you should never lower your page file, you should never set the file static...the amount of ram you have increases your need for a page file, it does not decrease the need...that was an old belief that is just not true in xp...xp has a designed need to page, and it needs all the ability to page your entire ram...you can't stop it from wanting to do it...now don't get the wrong idea, the OS is not using page instead of ram, in essence, it's preparing to use it...creating addresses, it needs and will have everything it wants, and it doesn't matter if you eliminated the page file, XP will still page the same, only not in the page file, it will find other places to page, and that'll be a huge performance hit...that's the first thing

    the second thing, you should never set the page file to a static value...this serves only a negative purpose, and there is no positive purpose to it...the old, information that you will prevent fragmentation is well proven obsolete...you see, the file remains static, it is a static file, even when it's set dynamic...IT ONLY EXPANDS WHEN IT IS ABSOLUTELY NECCCEASSARY...which would you rather have? the crash, or the MYTHICAL fragementation...I say mythical because even when the file expands, it returns to normal on reboot, and the new volume is erased...no fragmentation

    leave the default, which will be the necessary 1.5 of whatever your ram is, and you'll also be given the added safety of never having to worry if the file is too small.

    Here's the best method for smooth performance...set your ram to about double the ram as the smallest file, and then set expansion to the maximum allowed on the disk...this way, expansion will probably never incur, and In Case you do use all that ram that you have, there will be no penalty of the page file being too small, as xp will just expand it if it becomes necceary
     
  5. Spanko

    Spanko Guest

    Ok, so i set it to 768 minimum and 768 maximum. But still when i go to System Tools ----> System Information it says that my page files is over 1gb and my virtual memory is even higher. Even though I just set it to 768-768. Which is what you said i should set it to right dealer? Sorry if i misunderstood your post but it was kinda hard to read....
     
  6. andre9540

    andre9540 Guest

    exactly

    the same thing happened to me... the only thing i could do was install xp again not a clean just a dirty fixed it right up
     
  7. Perris Calderon

    Perris Calderon Moderator Staff Member Political User

    Messages:
    12,333
    Location:
    new york
    there should be no maximum...you see, what you do when younset a maximum, is you force xp to look somewhere else if it happens to need a bigger page file...leave the setting dynamic