Write cache on Hard Disk problem

Discussion in 'General Hardware' started by Nikmeister, Mar 29, 2002.

  1. Nikmeister

    Nikmeister Guest

    Hi all, when checking the event viewer I have a warning that the "driver disabled the write cache on device \Device\Harddisk2\DR5". This message appears every time after I boot up. Do you know what this might be attributed to and how I might resolve it? The other day when opening Outlook Express, XP just rebooted and stated it just recovered from a critical error. Does the same when playing games sometimes too. I don't know if the message and the actions are related but I thought I'd just add that info. I checked Windows' knowledge base but to no avail. I have a 40 G HD an 8 G partition and seperate 8 G Quantum HD. Can anyone help? Thanks in advance.
     
  2. Nikmeister

    Nikmeister Guest

    BTW, this was one of the critical error messages if it helps,
    "Error code 00000050, parameter1 ff541380, parameter2 00000000, parameter3 8055710b, parameter4 00000000".
     
  3. Binary

    Binary Guest

    Found the error here: www.jsiinc.com/SUBF/TIP2800/rh2806.htm and as far as I can tell the situation is linked to the UNMOUNTABLE_BOOT_VOLUME problem in WinXP, described here: support.microsoft.com/default.aspx?scid=kb;en-us;Q315403. What it boils down to is the fact that WinXP is sometimes shutting down too fast for the diskcache to be flushed properly. This is potentially dangerous (disasterous really) so they advise the cache to be disabled. Don't know if the rebooting has anything to do with it, but you can switch off automatic rebooting in System Properties > Advanced > Startup & Recovery. The system should then generate the proper errormessage, so you can identify the problem.
     
  4. Nikmeister

    Nikmeister Guest

    Thanks for the reply. I disabled write caching and I'm still getting the same error message in the event viewer right after booting. Any other suggestions?
     
  5. Nikmeister

    Nikmeister Guest

    I just went to check my options under policies for my hard drive and now the enable write caching radio button is clicked and greyed out without an option to disable it. This is the case on all hard drives. Any way to get that option back? Thanks