WMP associated with opening .exe files

Discussion in 'Windows Desktop Systems' started by buster33, Jul 18, 2008.

  1. buster33

    buster33 OSNN One Post Wonder

    Hello everyone. I did not find a match to my problem so I hope it is ok to post here.
    I have a Toshiba satelite notebook running Vista Home Premium and I find that just about everything I try to do, WMP ties to "play" the app or file.
    IE msconfig--regedit--AV apps--any programs or applications--system restore, all open WMP when I click on the app/program exe file.
    Even many Windows system tools and items in Control Panel also try to open with WMP.
    The option of Open With is not available on right click on the file and there is no .exe extension shown in the extension list to associate a particular app or program to it. Looking at files associated with WMP under Default Programs does not show .exe files. Only the usual video and sound files.
    Looking at the Properties of many of the exe files show the target as being correct but the "Start In" line is always blank.
    The Type of File is always shown as Windows Media Player (exe)

    I have started the machine in safe mode, but the same thing occurs.
    Starting in safe Mode Command Prompt Only allows me to access the registry but I cannot import any registry fixes
    I can also access msconfig in this mode, but disabling all in the startup does not resolve anything.
    I have done rstrui at the safe mode command prompt and although I was able select a restore point prior to the problem occuring, on restart, WMP ties to open whatever is in the Startup files. So that didn't work.

    I have tried to install a AV/spyware program from a thumb drive, but as soon as the drive is placed in a USB port, I am unable to do any task until the PC changes the files association of the apps on the thumb drive--then of course, the app is useless and will not install as WMP opens and tries to "play" it. NB: once the thumb drive is removed--the exe files are ok except each file name is now displayed like_this_on_every_file_name
    My only chance I think is to edit the registry, but I was not successful in trying to import a file someone sent me that they thought might do the trick. access denied.
    So, I guess it will require manual editing to see if I can fix it , but I only know enough to know that I don't mess about with that.
    Before I bite the bullet and format & reload, I thought I would see if any kind soul here could help me solve my problem.
    Any and all help will be greatly appreciated.

    thank you for reading
  2. JPRuss

    JPRuss OSNN Addict Folding Team

    In the unknown
    Are you able to get into the registry and delete a subkey?


    If this key exists look for a sub-key called UserChoice, if it exists, then delete it. This should revert back to original Windows Vista default.

    Hopefully this will fix it. Be very carefull editing the registry as back it up if possible first.

    Though the fact that a restore point didn't work is puzzling, there maybe something (virus?) re-editing the registry as fast as you fix the problem.
    bush dogg likes this.
  3. loaderbull

    loaderbull OSNN Junkie

    Midlands, UK
    Hi Buster,

    Have you tried going into Control Panel, and then Default Programs, then there is a list of options to choose from. Have a look in there and see if you can restore defaults.

    The two you might want are;

    1 - Set your default programs
    2 - Associate a file type or protocol with a program

    It does seem that something has changed these without your knowledge. Try the above if you can to access the net (i'm assuming you are using a different PC to post as you say that IE opens up WMP? Download the most recent Microsoft Malicious Software Removal Tool and run that, and run any scans that you can, if your own AV does not work, try a web based scanner.

    Hope that helps.
    Last edited: Jul 18, 2008
    bush dogg likes this.
  4. Shamus MacNoob

    Shamus MacNoob Moderator Political User

    L'Ile Perrot Quebec

    "Content Type"="application/x-msdownload"




    @="\"%1\" %*"







    1.From any of the folder windows windows, select folder option and click on the file type tab.
    2. Search for the the extension type with the name of exe.
    3. Remove it.
    4. Now to reassociate exe file, you need to paste the following text into a text file by using a notepad. While saving the file select all file and save as exe.reg.
    5. Double click the file the update te registry.
    6. Reboot for the changes to take effect.
    bush dogg likes this.
  5. buster33

    buster33 OSNN One Post Wonder

    Hello JPRuss,
    Your suggestion has done the trick and everything I have tried since making the adjustment in the registry as you suggested, seems to be back to original/default working order.
    All that remains now is to reget some updates that were wiped out by my attempts at Restore and to also update my AV program and do a full PC scan.
    Perhaps there may be some minor tweaks and housekeeping to do, but all appears to be fine now.
    I am so delighted to have found this forum at a suggestion of a friend of mine, and I am so pleased to find a member with your expertise that has been willing to help me.
    I appreciate you time and you consideration very much.

    Thank you too Shamus MacNoob.
    I still couldn't import the .reg file into the registry even though I set permissions to allow it, but I printed out your entries and I checked them one by one and made a couple of minor adjustments along the way.. thank you so much for your efforts too.

    loaderbull--thank you for your contribution also.
    I am a very happy person right now and it is thanks to you people .
    best wishes,