Windows XP + SP1 Update & Gaming... not working?

Discussion in 'Windows Desktop Systems' started by Rodders, Oct 11, 2002.

  1. Rodders

    Rodders Guest

    On a fresh install of Windows XP + SP1 everything seemed to be working fine & dandy. I updated all of my drivers (staying clear of the BETA) and installed my most used applications (nothing fancy, your average stuff like Office XP, NAV etc).
    Eventually I got round to installing a few games before I noticed some fairly major problems.

    I've gotton as far as installing four games; Combat Mission: Barbarossa to Berlin, Unreal Tournament 2003, NHL 2003 + FIFA 2003 the demo (yes.. I've noticed ;) )

    I tried running combat mission only to be greeted with the desktop straightaway. However it was still running, and you could see it in the task bar - it just wouldn't maximize (either by clicking it, alt-tab or with the task manager).

    Anyway after a lot of wasted time (and another reinstallation of XP - which doesn't bother me) I was greeted with the same problem again (which does irritate me - as it was about 4am at the time)
    Eventually I ended up (somehow) changing the desktop resolution to 800x600 and haven't had any problems since.
    so that works fine (providing I run it in 800x600 mode on the desktop) which again, I can settle for.

    Then, there's UT, FIFA and NHL 2003 - which all refuse to run for more than 5 or 6 seconds. The problem is almost certainly the same in each game, the main menus and everything work fine - but once you get into the game they crash to the desktop without an error (after approximately 5 seconds).
    If it was just one game that didn't work, I'd accept that, but clearly this is a system wide problem that's going to affect ALL my games, now, and in the future. And so I'd like to sort it out :)

    It's worth pointing out that I had the exact same setup beforehand (WITHOUT SP1) working - BUT I did have the same problem with CM:BB (I'm not sure what that is about though).

    No amount of Refresh Rate tweaks, Resolution changes or Driver updates/downgrades are doing the trick. The problem is always the same and always happens regardless of what I do.

    I'm more than willing to accept it's me at fault, and not the update. So any help would be appreciated!

    As you can imagine, this is now getting to the point where I'm considering downgrading to XP without SP1 :(
    But I'm not sure I should do this thanks to sites like grc.com playing up the importance of the update...

    Anyway thanks in advance :)

    ---------------------------
    AMD 1.2ghz
    32MB GForce2MX
    256MB RAM
    ---------------------------

    EDIT: If you could respond as soon as possible I'd be grateful
     
  2. Jz1397-5

    Jz1397-5 XP Bad Ass

    Messages:
    1,278
    Location:
    Philadelphia PA
    um, in the game are the settings set to the same ask desktop? EX Bit depth and so forth? with XPSP1 you can uninstall it, try that and then see. i don't think it would be SP1, i have not heard any other problems with video
     
  3. Rodders

    Rodders Guest

    I was mainly wondering whether it was a common problem and there was some kind of immediate fix.

    I know you can just uninstall these updates - but I've messed up my PC now beyond repair and I'd rather just format it (i haven't come a long way since reinstallation anyway). I've tried installing DirectX again and about 4 different Video Drivers.
    I guess I'm one of those people that likes a clean sheet - just to be on the safe side. And with my limited computer knowledge it usually works out for the best :)

    I think i was just hoping it was a simple fix I could apply the second time around.

    But yeah, it works without SP1 (as I mentioned) - nothing apart from that has changed, and I've done numerous reinstallations beforehand. No problems encountered.
     
  4. rettahc

    rettahc Guest

    I had a similar prob when I did a clean slipstreamed install of XP, what was happening on my system was that XP was not actually install the right vid driver, because my driver was unsigned, it was installing the built-in nvida driver without telling me. what I finally did to fix this was unistall the vid drivers, then I when I rebooted and it found the new device, I chose the select a driver from a list, and the chose the proper driver.

    Hope this helps
     
  5. Rodders

    Rodders Guest

    wouldn't this just result in XP reinstalling the exact same driver? I've never been offered the ability to select the driver I want from the list (like would happen in win9X). It always installs a default NVidia driver quietly, and then I update it from nvidias website/windows update without any problems (providing you ignore my SP1 troubles)
     
  6. rettahc

    rettahc Guest

    When the new hardware found wizard pops up select

    Install from a specific location.

    then on the next screen choose:

    Don't search I will choose the driver
     
  7. Rodders

    Rodders Guest

    well, now the problem is present without SP1 - but, it has to be said I did use windows Update. I just removed SP1 from the selection.

    However, I have had some luck - and that's by using the default Windows XP driver provided (not the one with SP1 installed mind you).
    Still, they are VERY slow, and you can't configure. So it's not ideal.

    I've leapt up to the 2832s (I assume it's up anyway) and found little success again.

    It's begining to drive me crazy :(

    Everything was working, I can't understand what's going on.

    Could it be those individual updates?

    Any ideas?
     
  8. Rodders

    Rodders Guest

    Turns out I needed the latest (beta) version of the VIA drivers. I've no idea why it was working previously and not now, maybe I had them installed without remembering... But either way I'm sorry to have bothered you all :)