Windows XP -- Lose Intenet Connection when Idle too long

Discussion in 'Windows Desktop Systems' started by BenLK, Sep 13, 2003.

  1. BenLK

    BenLK Guest

    I have a broadband ADSL connection, which is networked through an ethernet connection running through a Dynamode ADSL Router

    My main computer runs on Windows XP; the second device runs on the (awful) Windows Me and the third on Windows 98 Second Edition.

    On my XP computer, if my web connection stays idle for awhile (the critical time varies), I become unable to access any site that I have not previously accessed in that session. Using Mozilla, I get a message "unable to resolve host." Using IE, the browser simply cannot find the site.

    I had thought the problem might lie with my ISP, but oddly I NEVER have this problem with the Windows Me or Windows 98 machine.

    I've read one article that suggests the problem is XP caching unsuccessful DNS lookups, but the solution suggested in the article did not cure my problem.
    (See http://cable-dsl.home.att.net/dns_cache.htm)

    Any suggestions?
     
  2. grimman

    grimman Guest

    Try an alternate DNS-server?
     
  3. GoNz0

    GoNz0 NTFS Stoner

    Messages:
    2,781
    Location:
    the year 2525
    chances are the router has an idle disconnect setting, sods law if it kicks in you have to reboot the router. have you the link to an online manual so i can have a look for the setting ?
     
  4. BenLK

    BenLK Guest

    The DNS server I'm logged into is the one recommended by my ISP. Also, it works perfectly for my other two compuyters.

    The router is set to never disconnect. (Timeout -0-)

    Unfortunately the manual is not on line. The router is a Dynamode ADSL Router model R-ADSL-C4


    Ben
     
  5. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Goto your Control panel and then to your Network Connections. Now locate the Network connection you use to connect to the internet. Right Click on it and select Properties, In the General Tab Underneath the Connect Using Box, select Configure, goto the Power Management Tab and then make sure "Allow the computer to turn off this device to Save power" is unchecked.,

    Hope this helps...
     
  6. BenLK

    BenLK Guest

    The Blue Raja idea is very interesting. I have changed the setting as he suggests and will report back if that solves the problem.

    How would I swap DNS settings? Is that only on the computer or do I need to do something with my router as well?

    Ben
     
  7. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Im not sure TBH that the DNS thing is your problem. To check this the next time it happens, goto Start \ Run on the menu and type cmd to open a DOS window. In there type ipconfig /all. Here you will find out your IP address, the IP address of your Gateway, your DCHP server and the DNS server. Use the command ping in DOS to try and ping each one. I.e. ping 10.10.10.10 . (Ping the Gateway, then the SHCP then the DNS Server) If it comes back as Destination Unreachable or no reply from 10.10.10.10 let us know which one it is and we can take it from there.
     
  8. BenLK

    BenLK Guest

    Well, I changed the power management setting and it did not cure the problem.

    Previously when my connection failed I tried pinging the gateway and the DNS servers, which are the same address as my router. I get the proper reply.

    My connection is set so that it is not DHCP enabled.

    Very puzzling.


    Ben
     
  9. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Are you supposed to have a static IP address or a Dynamically allocated one?
     
  10. BenLK

    BenLK Guest

    I don't know. The technician who installed the network copied the settings from BT's original installation into the new router.

    If there was an error, he would have just copied it.

    Is this a router configuation issue or a PC configuration issue?

    If it is a router issue, why would it arise only with my XP machine?

    Ben
     
  11. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Well, to be honest if you can ping your gateway and your DNS server then yoru connection IS still up.

    But here is one to try....

    ping 212.58.226.40 and see if that works, then ping news.bbc.co.uk and see if that still works.

    the 212.x.x.x is the same site but you will not go through a DNS server to resolve the name. When you ping news.bbc.co.uk you will. So if one works and one dosent then you know where the problem is.

    Other than that i have to admit im struggling now. :(
     
  12. BenLK

    BenLK Guest

    Thanks. I'll try it next time the connection goes down.

    Ben
     
  13. BenLK

    BenLK Guest

    OK. Progress now. I lost the connection again after a couple of hours of inactivty.

    Then, pinging 212.58.226.40 worked but when I tried to pink news.bbc.co.uk it said "Ping request could not find host news.bbc.co.uk. Please check the name and try again."

    Now what do I do?
     
  14. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Right this is a problem with your DNS server, but i cant understand why it works on your other PCs? If you do ipconfig /all as above on your other machines - does it show that the IP address of the DNS server is the same as the one on your XP machine? But even this woulnt explain why it only falters after your PC has been idle for a while... :confused:

    Also, when this happens try the following command from DOS, ipconfig /flushdns and let me know if after this you can ping news.bbc.co.uk or use the web again.
     
  15. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    I have to say as well, that it does sound like the error described in your first post. Are you SURE you applied the registry file correctly? And restarted your PC?

    Also goto Start \ Run and type regedit then goto

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters

    Within there check that the following entries exist and that the value is set as indicated.

    "NegativeCacheTime"=0
    "NetFailureCacheTime"=0
    "NegativeSOACacheTime"=0

    Let me know.
     
  16. BenLK

    BenLK Guest

    Errr. I had tried that registry change but it hadn't solved the problem. If you think it makes sense I'll try it again, but I had been making just one change at a time so that I couuld be sure what made the difference.

    I'll do it now. Stay tuned for the result.

    Ben
     
  17. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Just take the file that is on that page and run it - this will add the settings for you.

    But you need to reset after they are applied in order for it to be activated.
     
  18. BenLK

    BenLK Guest

    It turns out that although I had thought I had removed that registry entry, I had not. So it's been there in my registry all along, but it has not done the job.

    Big sigh. Seems hopeless.

    Ben
     
  19. TheBlueRaja

    TheBlueRaja BR to Some

    Messages:
    766
    Location:
    Fawkirk!
    Can you supply me with the information i requested above....
     
  20. BenLK

    BenLK Guest

    I should add that I have also tried the flushdns suggestion, and that has not worked either. Rebooting the computer always solves the problem