Windows xp cannot see workgroup

Discussion in 'Windows Desktop Systems' started by noot, Oct 2, 2002.

  1. noot

    noot Guest

    Ok, the story. I have a home network consisting of (2) win98se machines, (1) win2k pro machine, and my laptop running which was dual booting win2k and winxp. Everything worked flawlessly for about 8 months. I decided to remove my dual boot and reinstall winxp pro since I no longer needed win2k. When I reinstalled, downloaded all updates, switched workgroups back to mine and tried to browse my network. I got this message:
    "xxxxx is not accessible. You might not have permission to use this network resource. Contace the administrator of this server to find out if you have access permissions.

    The network path was not found."
    I then went into the win2k machine and could see my laptop as well as the others on the network. I could not access my laptop from the win2k machine however. I got the message "the network path was not found."

    I then pinged the laptop name from the 2k machine and got full response. I then tried to ping the 2k machine from my laptop using ping nunakim. The laptop sees the address of nuankim)win 2k machine) but does not get any reply from it. Constant time out.

    I have been scratching my brain on this one and have even reinstalled the OS on my laptop (3) times. I even tried using a USB nic adapter to see if that was the problem. That didnt resolve anything however.

    I can also ping my gateway still from all machines and have internet access through them as well. Even the laptop. I can ping the rest of the world, just not my own workgroup. I have already went in and enabled NetBIOS over TCP/IP on the laptop(winxp pro). And also the registry string for browser management.

    I am completely at a loss and cannot understand why I cannot see my network. I have double and triple checked every connection, setting and every other possibility I know of.

    If anyone can help, please do so. Any suggestions will be appreciated.

    Thanks,
    Corey Townsend
     
  2. Zedric

    Zedric NTFS Guru Folding Team

    Messages:
    4,006
    Location:
    Sweden
    Sounds like the permissions are wrong. Can't really see why though. Is the user different on the laptop now?
     
  3. rettahc

    rettahc Guest

    do you have the XP firewall turned on?
     
  4. Rootz

    Rootz Guest

    I guess should be a network protocol issue...
    Happened to me once: machines talked in a mixed workgroup as long as I called them by IP address. Calling them by names often worked but if I tried to browse *entire network* I got access denied or network path not found.
    That strage work/dontwork situation was due to netbios over tcp/ip, netbeui and tcp/ip conflicts between NT and 9x machine.
    I solved the problem by installing WINS on a server.
    If your network is small (no server) and has static address configuration the best solution would be compiling both correct HOSTS and LMHOSTS files containing all IP and name correspondance on the network and then place them on each machine.
    This would 100% workaround whatever kind of network resolution problem... the inconvenience is that you haver to manually change each file on each system in case you change either IP address or machine name.
     
  5. noot

    noot Guest

    Zedric, thanks for the reply. Its not that I cannot get into files set by permissions by the 2k machine. I cannot ping the machine from a DOS prompt using the username of the 2k machine or by using its static IP.

    Rettahc, Thank you as well. The xp firewall is off.

    Rootz, What you are talking about is the exact issue Im facing I believe. I just dont understand why it continues to not see the other machines. The 2k machine can see the laptop, but cannot access it. The laptop cant see a thing no matter what. However, it is odd that I can ping nunakim(win 2k machine) and it sees the machine, translates the word nunakim to its static IP but still will not reply. I would hate to compile both coreect HOSTS and LMHOSTS files to fix it. But if that will work, then I guess that I will have to give it a shot. Im just puzzled as to why it wouldnt work when I reloaded my OS. User name , workgroup, everything is the same. No changes whatsoever.

    Corey
     
  6. Rootz

    Rootz Guest

    just thinking... what kind of a workgroup network is yours?
    is it a UNC cabled peer-to-peer network or you connect the computers with UTP cables through hub/switch/router?
    that might be useful...

    don't get puzzled because in such a scenario the computers put in a cache the routing, Wins and DNS tables (sort of dynamic HOSTS and LMHOSTS, that's why I told you to try with forced static settings) which will last a single session, at each reboot the cache is flushed deleting both working and non-working name and IP resolution records.

    Have you also tried installing netbeui on NT machines? might help name resolution in a workgroup or peer to peer network.
     
  7. Rootz

    Rootz Guest

    another thing...
    you say your 2k machine has a static IP configuration... now what about the others?
    you sure that all machines have compliant IP class and subnet mask?
    If you have a class C (commonly 192.168.x.x with subnet 255.255.255.0) address on 2k and automatic private ip address (APIPA which uses class B 169.254.x.x with a subnet of 255.255.0.0) assigns dynamic IPs to other machine, then you'll see also that some machines randomly talk with each other but more often not.
    Always check IP configuration (including default gateway which must be the same for all machines) when troubleshooting these problems.
    The occurrance of such conflicts would cut off all doubts on what's going on...
     
  8. noot

    noot Guest

    Rootz,
    Again thank you for the replys. Im using a DLink router to connect everything. I havent installed netbeui on anything yet. The 2k and xp machines both are running ntfs.

    The other machines are running a class C address. I will try installing netbeui to see what happens. Thanks again.
     
  9. noot

    noot Guest

    Finished installing netbui on the two machines in question. Same problem. I am sure that this is a problem with my win2k machine now however though. I put one of my other laptops on the same network and get the same results. The two laptops can ping and see each other. The win2k machine can see the laptops but cannot access them. Neither of the laptops can see nor ping the win2k machine. Very odd to say the least.

    Corey
     
  10. claughaun

    claughaun Guest

    I had the same problem when I switched my main pc to Win XP from 98. I eventually sorted it out by setting the network back up under a different name. In the "new" network the local pcs have dynamic ip addresses as opposed to the fixed address I used in 98 - 192.168.0.x - works fine now, but was a painful transition. The wizard diskette created by the main pc sorted out the local pc's....hope this helps.
     
  11. noot

    noot Guest

    claughaun,
    Thanks for the tip. I may just give that a try as well. Im just about to turn one of these machines into an end table if I dont come across a solution. Ill try about anything right now.

    Corey