Windows Virtual Memory set too low?

Discussion in 'Windows Desktop Systems' started by Heeter, May 11, 2004.

  1. Heeter

    Heeter Overclocked Like A Mother

    Messages:
    2,732
    Hi Guys,

    I get this error when I play my new game "Far Cry". I think that I have enough specs hardware wise to play this game. ('Puter specs listed below) I do keep getting errors/freezes while playing. How can I fix this Virt.Mem. problem? It is set at system manged pagefile (523Megs listed in the E: partition. I have a C:\, D:\, E:\ partitioned Harddrive) under my MyComputer->Properties->Advanced tab.

    Thanks in advance

    Heeter
     
  2. Xie

    Xie - geek - Subscribed User Folding Team

    Messages:
    5,275
    Location:
    NY, USA
    Well if you have it set to system managed it should be fine as long as the partition has enough space for your pagefile to expand (probably enough room for it to be 1.5 your RAM is good). What are the errors though?
     
  3. Heeter

    Heeter Overclocked Like A Mother

    Messages:
    2,732
    They are game errors, mostly. Although, I haven't had one since I changed my "system managed" to Custom and put in 767Megs. I couldn't read the errors as it came up too fast to read, then it just freezes. Will continue at Custom pagefile settings to see if it was the problem.

    I have searched the ubisoft site for any patches, doesn't seem to be any that will resolve my situation with the game itself.

    Thanks Xie.

    Heeter
     
  4. ming

    ming OSNN Advanced

    Messages:
    4,252
    Location:
    UK
    On my desktops, Windows automatically allocates 768MB of VM, even though I have 768MB RAM in one, and only 512MB in the other.
    On my laptop, it's set the VM to 512MB even though I only have 256MB RAM.
    I've always been told to allocate 1.5x the amount of RAM for the VM you have in your machine.
     
  5. LeeJend

    LeeJend Moderator

    Messages:
    5,291
    Location:
    Fort Worth, TX
    Heeter you may want to up the RAM to 768MB. I was running 512 and BFV was very ornery. Added a 3rd stick and now it plays fine.

    Other possibility is your FSB is pushed too hard. If I go over 188 FSB my games start crashing after a while. Roll it back to 190 and see if that helps.
     
  6. Heeter

    Heeter Overclocked Like A Mother

    Messages:
    2,732
    Thanks for the ideas, Leejend.

    I have moved it back to "System Managed" from "custom", and it has been running flawless since. I don't know why it was putting up a fight before this. Oh well.

    BTW, the graphics/sounds are astounding on this game. So far, well worth the $60 that I paid.

    Heeter
     
  7. melon

    melon MS-DOS 2.0 Political User

    Messages:
    854
    Location:
    Ásgarðr
    I have a large enough hard drive that I just set it to "custom managed" and put it at the maximum: 4096 MB (both the initial and maximum settings). Windows XP won't let you go any bigger than that, and I haven't had any issues with virtual memory since.

    Melon